summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-04-01 16:21:26 +0000
committerMarinus Schraal <foser@gentoo.org>2003-04-01 16:21:26 +0000
commit5142d0ee6cbc2678fc7813d632842de60ba8323b (patch)
treec1bd1e62d2fedfcdec2dfc146cdab907ca724f18 /app-office/abiword
parentminor version bump (diff)
downloadhistorical-5142d0ee6cbc2678fc7813d632842de60ba8323b.tar.gz
historical-5142d0ee6cbc2678fc7813d632842de60ba8323b.tar.bz2
historical-5142d0ee6cbc2678fc7813d632842de60ba8323b.zip
added build fixing patch
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog5
-rw-r--r--app-office/abiword/abiword-1.1.4.ebuild19
-rw-r--r--app-office/abiword/files/abiword-1.1.4-wv_configure_fooling.patch45
3 files changed, 67 insertions, 2 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 9f42e75602fb..8d2a30208813 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.30 2003/03/31 23:06:24 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.31 2003/04/01 16:21:26 foser Exp $
*abiword-1.1.4 (31 Mar 2003)
+ 01 Apr 2003; foser <foser@gentoo.org> abiword-1.1.4.ebuild :
+ Added patch for configure to make the wv tests work
+
31 Mar 2003; foser <foser@gentoo.org> abiword-1.1.4.ebuild :
GTK+2 development release
diff --git a/app-office/abiword/abiword-1.1.4.ebuild b/app-office/abiword/abiword-1.1.4.ebuild
index 9e7461cd2166..9fde1aa8e374 100644
--- a/app-office/abiword/abiword-1.1.4.ebuild
+++ b/app-office/abiword/abiword-1.1.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.1.4.ebuild,v 1.1 2003/03/31 23:06:24 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.1.4.ebuild,v 1.2 2003/04/01 16:21:26 foser Exp $
+
+inherit eutils
IUSE="perl build spell jpeg xml2 gnome"
@@ -30,6 +32,21 @@ DEPEND="virtual/x11
>=gnome-extra/gal-1.99 )
!app-shells/bash-completion"
+src_unpack() {
+ unpack ${A}
+
+ # Patch to make the wv.h tests work
+ #
+ # wv wants libole2 which in it's turn wants glib 1.2
+ # glib.h includes glibconfig.h which is in a non-included path
+ # and makes the tests fail, this patch adds those paths to configure.
+ # Compiling without specifying the path anywhere goes fine.
+ #
+ # April 1st 2003 <foser@gentoo.org>
+ cd ${S}
+ epatch ${FILESDIR}/${P}-wv_configure_fooling.patch
+}
+
src_compile() {
local myconf
diff --git a/app-office/abiword/files/abiword-1.1.4-wv_configure_fooling.patch b/app-office/abiword/files/abiword-1.1.4-wv_configure_fooling.patch
new file mode 100644
index 000000000000..75918706cbe5
--- /dev/null
+++ b/app-office/abiword/files/abiword-1.1.4-wv_configure_fooling.patch
@@ -0,0 +1,45 @@
+--- configure.old 2003-04-01 16:33:04.000000000 +0200
++++ configure 2003-04-01 17:47:45.000000000 +0200
+@@ -9168,7 +9168,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lwv $abi_wv_libs $LIBS"
++LIBS="-lwv $abi_wv_libs $LIBS -I/usr/lib/glib/include"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -9287,7 +9287,7 @@
+ #include <wv.h>
+ _ACEOF
+ if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
+- (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
++ (eval $ac_cpp -I/usr/lib/glib/include conftest.$ac_ext) 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+@@ -9391,13 +9391,13 @@
+ _ACEOF
+ rm -f conftest.$ac_objext
+ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>&5
++ (eval $ac_compile -I/usr/lib/glib/include ) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+ { ac_try='test -s conftest.$ac_objext'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
++ (eval $ac_try -I/usr/lib/glib/include ) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+@@ -9425,7 +9425,7 @@
+ #include <wvexporter.h>
+ _ACEOF
+ if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
+- (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
++ (eval $ac_cpp -I/usr/lib/glib/include conftest.$ac_ext) 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1