summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-08-28 14:59:00 +0000
committerMamoru Komachi <usata@gentoo.org>2004-08-28 14:59:00 +0000
commitf8e075ec89d8110f703a017c92b850fe738f5c29 (patch)
tree03176c94cb94407c237ec77c59cf66b7b73b8b35 /app-office/texmacs/texmacs-1.0.4.1.ebuild
parentx86 stable (diff)
downloadhistorical-f8e075ec89d8110f703a017c92b850fe738f5c29.tar.gz
historical-f8e075ec89d8110f703a017c92b850fe738f5c29.tar.bz2
historical-f8e075ec89d8110f703a017c92b850fe738f5c29.zip
Version bumped. Removed old ebuilds.
Diffstat (limited to 'app-office/texmacs/texmacs-1.0.4.1.ebuild')
-rw-r--r--app-office/texmacs/texmacs-1.0.4.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-office/texmacs/texmacs-1.0.4.1.ebuild b/app-office/texmacs/texmacs-1.0.4.1.ebuild
new file mode 100644
index 000000000000..28a0b7044761
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.4.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.4.1.ebuild,v 1.1 2004/08/28 14:59:00 usata Exp $
+
+# although flag-o-matic functions in portage, we should inherit it
+inherit flag-o-matic
+
+MY_P=${P/tex/TeX}-src
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="GNU TeXmacs is a free GUI scientific editor, inspired by TeX and GNU Emacs."
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="spell"
+# TeXmacs 1.0.X -> stable release, TeXmacs 1.0.X.Y -> development release
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+RDEPEND="virtual/tetex
+ >=dev-util/guile-1.4
+ >=sys-apps/sed-4
+ virtual/x11
+ spell? ( >=app-text/ispell-3.2 )"
+
+DEPEND="${RDEPEND}
+ virtual/ghostscript"
+
+src_compile() {
+
+ # we're not trusting texmacs optimisations here, so
+ # we only want the following two
+ strip-flags
+ append-flags -fno-default-inline
+ append-flags -fno-inline
+
+ econf || die
+ # and now replace the detected optimisations with our safer ones
+ sed -i "s:\(^CXXOPTIMIZE = \).*:\1${CXXFLAGS}:" src/common.makefile
+ # emake b0rked
+ emake -j1 || die
+
+}
+
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ dodoc COMPILE COPYING LICENSE
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/TeXmacs.desktop
+
+ # now install the fonts
+ cd ${WORKDIR}
+ dodir /usr/share/texmf
+ cp -r fonts ${D}/usr/share/texmf/
+
+}