summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-12 07:33:48 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-12 07:33:48 +0000
commita4e7be543b0187ffd0316f4bde1a80d88cdbe313 (patch)
tree76e096fe338eb3dcf1cd2b93d71faf90cad403ed /app-office/texmakerx/texmakerx-2.1.ebuild
parent[bump] dev-perl/Params-Validate-1.0.0 (diff)
downloadhistorical-a4e7be543b0187ffd0316f4bde1a80d88cdbe313.tar.gz
historical-a4e7be543b0187ffd0316f4bde1a80d88cdbe313.tar.bz2
historical-a4e7be543b0187ffd0316f4bde1a80d88cdbe313.zip
Addition, #338436
Package-Manager: portage-2.2.0_alpha40/cvs/Linux x86_64
Diffstat (limited to 'app-office/texmakerx/texmakerx-2.1.ebuild')
-rw-r--r--app-office/texmakerx/texmakerx-2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-office/texmakerx/texmakerx-2.1.ebuild b/app-office/texmakerx/texmakerx-2.1.ebuild
new file mode 100644
index 000000000000..3deaffc766f7
--- /dev/null
+++ b/app-office/texmakerx/texmakerx-2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmakerx/texmakerx-2.1.ebuild,v 1.1 2011/06/12 07:33:48 jlec Exp $
+
+EAPI=4
+
+inherit base qt4-r2
+
+DESCRIPTION="Fork of the LaTeX IDE TexMaker"
+HOMEPAGE="http://texmakerx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/TexMakerX%202.1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEPEND="
+ app-text/poppler[qt4]
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/qt-gui-4.6.1:4
+ >=x11-libs/qt-core-4.6.1:4
+ >=x11-libs/qt-webkit-4.6.1:4
+ >=app-text/hunspell-1.2.4"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}"/${P/-/}
+
+PATCHES=( "${FILESDIR}/${P}-hunspell.patch" )
+
+src_prepare() {
+ find hunspell -delete
+ sed 's:hunspell/hunspell:hunspell:g' -i *.h || die
+ qt4-r2_src_prepare
+}