summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-03-18 22:35:00 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-03-18 22:35:00 +0000
commit09236905e094c6bb0a54ed03ca7fae296edaba41 (patch)
treeccb17ba61f1b1d338080910be7f27980f8a85494 /app-office
parentchanged fcron user + group usage (diff)
downloadhistorical-09236905e094c6bb0a54ed03ca7fae296edaba41.tar.gz
historical-09236905e094c6bb0a54ed03ca7fae296edaba41.tar.bz2
historical-09236905e094c6bb0a54ed03ca7fae296edaba41.zip
Fix bug #167480 and #171290.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kexi/ChangeLog8
-rw-r--r--app-office/kexi/files/digest-kexi-1.6.2-r13
-rw-r--r--app-office/kexi/files/kexi-1.6.2-build_kexi_file.diff15
-rw-r--r--app-office/kexi/kexi-1.6.2-r1.ebuild50
-rw-r--r--app-office/koffice/ChangeLog8
-rw-r--r--app-office/koffice/files/digest-koffice-1.6.2-r13
-rw-r--r--app-office/koffice/files/kexi-1.6.2-build_kexi_file.diff15
-rw-r--r--app-office/koffice/koffice-1.6.2-r1.ebuild100
8 files changed, 200 insertions, 2 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index 94c2297e3f8a..7c8d397ff84d 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.74 2007/03/02 02:53:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.75 2007/03/18 22:35:00 carlo Exp $
+
+*kexi-1.6.2-r1 (18 Mar 2007)
+
+ 18 Mar 2007; Carsten Lohrke <carlo@gentoo.org>
+ +files/kexi-1.6.2-build_kexi_file.diff, +kexi-1.6.2-r1.ebuild:
+ Fix bug #167480 and #171290.
02 Mar 2007; Jeroen Roovers <jer@gentoo.org> kexi-1.6.1.ebuild:
Stable for HPPA.
diff --git a/app-office/kexi/files/digest-kexi-1.6.2-r1 b/app-office/kexi/files/digest-kexi-1.6.2-r1
new file mode 100644
index 000000000000..cfd7d14fcad4
--- /dev/null
+++ b/app-office/kexi/files/digest-kexi-1.6.2-r1
@@ -0,0 +1,3 @@
+MD5 74ef62a5f8f766fe8192d5b7d65a3928 koffice-1.6.2.tar.bz2 57049103
+RMD160 fb4ef5870870d80481a4a9d2864199428f495460 koffice-1.6.2.tar.bz2 57049103
+SHA256 fa5ca02eba02219d34c3c6efff92bf767060b4b1343da56eb63139661d53f380 koffice-1.6.2.tar.bz2 57049103
diff --git a/app-office/kexi/files/kexi-1.6.2-build_kexi_file.diff b/app-office/kexi/files/kexi-1.6.2-build_kexi_file.diff
new file mode 100644
index 000000000000..bd235d9591da
--- /dev/null
+++ b/app-office/kexi/files/kexi-1.6.2-build_kexi_file.diff
@@ -0,0 +1,15 @@
+--- branches/koffice/1.6/koffice/kexi/examples/build_kexi_file.sh 2007/01/24 18:50:22 626851
++++ branches/koffice/1.6/koffice/kexi/examples/build_kexi_file.sh 2007/02/15 13:50:16 633840
+@@ -8,8 +8,10 @@
+ # ksqlite is needed on the $PATH.
+
+ KEXISQL3PATH=../3rdparty/kexisql3/src/.libs/
+-PATH=$PATH:$KEXISQL3PATH
+-LD_LIBRARY_PATH=$KEXISQL3PATH:$KEXISQL3PATH
++PATH=$KEXISQL3PATH:$PATH
++export PATH
++LD_LIBRARY_PATH=$KEXISQL3PATH:$LD_LIBRARY_PATH
++export LD_LIBRARY_PATH
+ which ksqlite > /dev/null || exit 1
+
+ [ $# -lt 1 ] && echo "Missing .sql filename." && exit 1
diff --git a/app-office/kexi/kexi-1.6.2-r1.ebuild b/app-office/kexi/kexi-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..836d26817ef0
--- /dev/null
+++ b/app-office/kexi/kexi-1.6.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.6.2-r1.ebuild,v 1.1 2007/03/18 22:35:00 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres kdeenablefinal"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ sys-libs/readline
+ mysql? ( virtual/mysql )
+ postgres? ( <dev-libs/libpqxx-2.6.9 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoproperty lib/koproperty
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkrossmain lib/kross/main/
+ libkrossapi lib/kross/api/"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.4
+
+PATCHES="${FILESDIR}/kexi-1.6.2-build_kexi_file.diff"
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"
+
+ # Labplot needs the header file
+ sed -i -e "s:utils.h:utils.h parser/parser.h:" kexi/kexidb/Makefile.am || die "sed failed"
+ kde-meta_src_compile
+}
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index ad48f21e7fc6..9b682d77ba39 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.216 2007/02/23 20:55:48 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.217 2007/03/18 22:33:00 carlo Exp $
+
+*koffice-1.6.2-r1 (18 Mar 2007)
+
+ 18 Mar 2007; Carsten Lohrke <carlo@gentoo.org>
+ +files/kexi-1.6.2-build_kexi_file.diff, +koffice-1.6.2-r1.ebuild:
+ Fix bug #167480 and #171290.
23 Feb 2007; Charlie Shepherd <masterdriverz@gentoo.org>
koffice-1.6.2.ebuild:
diff --git a/app-office/koffice/files/digest-koffice-1.6.2-r1 b/app-office/koffice/files/digest-koffice-1.6.2-r1
new file mode 100644
index 000000000000..cfd7d14fcad4
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.6.2-r1
@@ -0,0 +1,3 @@
+MD5 74ef62a5f8f766fe8192d5b7d65a3928 koffice-1.6.2.tar.bz2 57049103
+RMD160 fb4ef5870870d80481a4a9d2864199428f495460 koffice-1.6.2.tar.bz2 57049103
+SHA256 fa5ca02eba02219d34c3c6efff92bf767060b4b1343da56eb63139661d53f380 koffice-1.6.2.tar.bz2 57049103
diff --git a/app-office/koffice/files/kexi-1.6.2-build_kexi_file.diff b/app-office/koffice/files/kexi-1.6.2-build_kexi_file.diff
new file mode 100644
index 000000000000..bd235d9591da
--- /dev/null
+++ b/app-office/koffice/files/kexi-1.6.2-build_kexi_file.diff
@@ -0,0 +1,15 @@
+--- branches/koffice/1.6/koffice/kexi/examples/build_kexi_file.sh 2007/01/24 18:50:22 626851
++++ branches/koffice/1.6/koffice/kexi/examples/build_kexi_file.sh 2007/02/15 13:50:16 633840
+@@ -8,8 +8,10 @@
+ # ksqlite is needed on the $PATH.
+
+ KEXISQL3PATH=../3rdparty/kexisql3/src/.libs/
+-PATH=$PATH:$KEXISQL3PATH
+-LD_LIBRARY_PATH=$KEXISQL3PATH:$KEXISQL3PATH
++PATH=$KEXISQL3PATH:$PATH
++export PATH
++LD_LIBRARY_PATH=$KEXISQL3PATH:$LD_LIBRARY_PATH
++export LD_LIBRARY_PATH
+ which ksqlite > /dev/null || exit 1
+
+ [ $# -lt 1 ] && echo "Missing .sql filename." && exit 1
diff --git a/app-office/koffice/koffice-1.6.2-r1.ebuild b/app-office/koffice/koffice-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..09bfed66603f
--- /dev/null
+++ b/app-office/koffice/koffice-1.6.2-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.6.2-r1.ebuild,v 1.1 2007/03/18 22:33:00 carlo Exp $
+
+inherit kde
+
+RV="${PV}"
+MY_P="koffice-${RV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="KOffice is an integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+SRC_URI="mirror://kde/stable/koffice-${PV}/src/${P}.tar.bz2"
+#SRC_URI="mirror://kde/unstable/koffice-${PV/_/-}/src/${MY_P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# See bug #130442.
+#IUSE="doc mysql opengl postgres"
+IUSE="doc mysql postgres"
+
+RDEPEND=">=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline
+ mysql? ( virtual/mysql )
+ postgres? ( <dev-libs/libpqxx-2.6.9 )
+ virtual/python
+ dev-lang/ruby
+ >=app-text/wv2-0.1.9
+ >=app-text/libwpd-0.8.2
+ >=media-gfx/imagemagick-6.2.5.5
+ >=media-libs/lcms-1.15
+ media-libs/tiff
+ media-libs/jpeg
+ >=media-libs/openexr-1.2.2-r2
+ media-libs/libpng
+ >=media-libs/libexif-0.6.13-r1
+ virtual/opengl
+ virtual/glu"
+# opengl? ( virtual/opengl virtual/glu )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
+
+need-kde 3.4
+
+# TODO: kword sql plugin needs Qt compiled with sql support
+# the dependency on python is needed for scripting support in kexi
+# and for kivio/kiviopart/kiviosdk.
+
+PATCHES="${FILESDIR}/kexi-1.6.2-build_kexi_file.diff"
+
+pkg_setup() {
+ # use opengl &&
+ if ! built_with_use =x11-libs/qt-3* opengl ; then
+ eerror "You need to build x11-libs/qt with opengl use flag enabled."
+ die
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+ # FIXME - disable broken tests for now
+ sed -i -e "s:TESTSDIR =.*:TESTSDIR=:" ${S}/krita/core/Makefile.am \
+ `ls ${S}/krita/colorspaces/*/Makefile.am`
+ sed -i -e "s:toolbar tests:toolbar:" ${S}/kplato/Makefile.am
+
+ # Labplot needs the header file
+ sed -i -e "s:utils.h:utils.h parser/parser.h:" ${S}/kexi/kexidb/Makefile.am || die "sed failed"
+}
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+ # $(use_enable opengl gl)"
+
+ kde_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ dodoc changes-*
+}