summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYi Quang <khai@gentoo.org>2004-04-11 18:07:51 +0000
committerYi Quang <khai@gentoo.org>2004-04-11 18:07:51 +0000
commit2d8bd747ceffb4772d2e8f18fdb1c2303a0aced0 (patch)
tree221aa2c9221ea67f6ae62d32924ba31328a07ff3 /app-office
parentMarked stable on all arches to satisfy dev-lang/ruby dep (diff)
downloadhistorical-2d8bd747ceffb4772d2e8f18fdb1c2303a0aced0.tar.gz
historical-2d8bd747ceffb4772d2e8f18fdb1c2303a0aced0.tar.bz2
historical-2d8bd747ceffb4772d2e8f18fdb1c2303a0aced0.zip
Bug fix release, should deprecate the amd64 patch.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/Manifest12
-rw-r--r--app-office/abiword/abiword-2.0.6.ebuild101
-rw-r--r--app-office/abiword/files/digest-abiword-2.0.61
3 files changed, 109 insertions, 5 deletions
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index df585b9082b4..b7f6a3822017 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,15 +1,17 @@
-MD5 332605c9a065c5fb995fd7bfacf3b319 ChangeLog 10519
MD5 7921df3134ed60f1eb9c3d1c920bde16 abiword-1.0.6-r1.ebuild 1927
MD5 f8ed2f89b5cd1abf83ecd4a6f5344821 abiword-2.0.1.ebuild 2179
-MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 abfb2e2e507d908d06169c5a8d4378d5 abiword-2.0.2.ebuild 2266
-MD5 cf9dcca5745cda8078a0386993cc0d8a abiword-2.0.5.ebuild 2542
MD5 232c5a4ec65a706f4b1436df697891df abiword-2.0.3-r1.ebuild 2541
+MD5 cf9dcca5745cda8078a0386993cc0d8a abiword-2.0.5.ebuild 2542
+MD5 ef14059ce0b1c9a3a8cf93c5b0b7390b abiword-2.0.6.ebuild 2129
+MD5 abfb2e2e507d908d06169c5a8d4378d5 abiword-2.0.2.ebuild 2266
+MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 332605c9a065c5fb995fd7bfacf3b319 ChangeLog 10519
+MD5 ddf70a53b4fc5671c7ed5cb4acb4a6e8 files/digest-abiword-2.0.3-r1 68
MD5 31616e14907aefda2489036cc3d1db3d files/AbiWord.desktop 901
MD5 1ebcd22c6249c06e631c13491113d8ef files/AbiWord2.desktop 166
+MD5 21b957a82d91b6a8d57c7cfa4779a094 files/digest-abiword-2.0.6 67
MD5 28dcae4a10f58c12a4a73346a7ab1ed0 files/digest-abiword-2.0.1 142
MD5 20b01c6c3348c63e1b088cf107398e0c files/digest-abiword-2.0.2 68
MD5 de17339aaab5c0b950381a7f36cf4c58 files/digest-abiword-2.0.5 68
-MD5 ddf70a53b4fc5671c7ed5cb4acb4a6e8 files/digest-abiword-2.0.3-r1 68
MD5 cd037c182094f6ba10b7dd9e15035efd files/abiword-2.0.3-amd64.patch 8632
MD5 55d85bca7cd645ef338336da3d6e6a7e files/digest-abiword-1.0.6-r1 67
diff --git a/app-office/abiword/abiword-2.0.6.ebuild b/app-office/abiword/abiword-2.0.6.ebuild
new file mode 100644
index 000000000000..811588a3423e
--- /dev/null
+++ b/app-office/abiword/abiword-2.0.6.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.6.ebuild,v 1.1 2004/04/11 18:07:51 khai Exp $
+
+inherit eutils
+
+IUSE="spell jpeg xml2 gnome debug doc"
+
+S_P=${S}/${PN}-plugins
+S_D=${S}/${PN}-docs
+S=${WORKDIR}/${P}/abi
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64"
+LICENSE="GPL-2"
+SLOT="2"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=media-libs/fontconfig-2.1
+ media-libs/libpng
+ >=x11-libs/gtk+-2.2
+ >=gnome-base/libglade-2
+ >=app-text/wv-1
+ >=dev-libs/fribidi-0.10.4
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ !xml2? ( dev-libs/expat )
+ spell? ( >=app-text/enchant-1 )
+ gnome? ( >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprint-2.2.1
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-base/libbonobo-2 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ `use_enable gnome` \
+ `use_with xml2 libxml2` \
+ `use_enable spell enchant` \
+ `use_enable debug` \
+ --enable-bidi \
+ --enable-threads \
+ --without-ImageMagick \
+ --disable-scripting \
+ --disable-gucharmap \
+ --with-sys-wv || die
+
+ emake all-recursive || die
+
+ # Build plugins
+
+ cd ${S_P}
+
+ econf \
+ `use_enable debug` \
+ --enable-all \
+ --with-abiword=${S} \
+ --without-ImageMagick || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib}
+
+ einstall PERLDEST=${D} || die
+
+ dosed "s:Exec=abiword:Exec=abiword-2.0:" /usr/share/applications/abiword.desktop
+
+ rm -f ${D}/usr/bin/abiword-2.0
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.0 /usr/bin/abiword-2.0
+
+ dodoc COPYING *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+
+ # install plugins
+
+ cd ${S_P}
+
+ make DESTDIR=${D} install || die
+
+ # install documentation
+
+ cd ${WORKDIR}/${P}/abiword-docs
+ sed -e 's:prefix = /usr/local:prefix = /usr:g' Makefile > Makefile.new
+ mv Makefile.new Makefile
+ make DESTDIR=${D} || die
+
+}
+
+USE_DESTDIR="1"
diff --git a/app-office/abiword/files/digest-abiword-2.0.6 b/app-office/abiword/files/digest-abiword-2.0.6
new file mode 100644
index 000000000000..259d7e2e539e
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-2.0.6
@@ -0,0 +1 @@
+MD5 6bfd9bb3d11ce7558e9235a427f9883e abiword-2.0.6.tar.gz 25914104