summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2008-11-13 06:18:49 +0000
committerFederico Ferri <mescalinum@gentoo.org>2008-11-13 06:18:49 +0000
commit459bfbc00e142a0d3d41e81ac2d5944fbf139feb (patch)
treed8ab85a284801164075142931bcb146092695266 /app-pda/synce-librapi2
parentamd64 stable, bug 245178 (diff)
downloadhistorical-459bfbc00e142a0d3d41e81ac2d5944fbf139feb.tar.gz
historical-459bfbc00e142a0d3d41e81ac2d5944fbf139feb.tar.bz2
historical-459bfbc00e142a0d3d41e81ac2d5944fbf139feb.zip
getting synce-0.12 into tree. ebuild coming from synce overlay, reviewed and tested.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-pda/synce-librapi2')
-rw-r--r--app-pda/synce-librapi2/ChangeLog12
-rw-r--r--app-pda/synce-librapi2/synce-librapi2-0.11.1.ebuild23
-rw-r--r--app-pda/synce-librapi2/synce-librapi2-0.12.ebuild30
3 files changed, 63 insertions, 2 deletions
diff --git a/app-pda/synce-librapi2/ChangeLog b/app-pda/synce-librapi2/ChangeLog
index d10f5d78ab84..9a171029b985 100644
--- a/app-pda/synce-librapi2/ChangeLog
+++ b/app-pda/synce-librapi2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-pda/synce-librapi2
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librapi2/ChangeLog,v 1.24 2007/10/06 19:23:07 dertobi123 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librapi2/ChangeLog,v 1.25 2008/11/13 06:15:06 mescalinum Exp $
+
+*synce-librapi2-0.12 (13 Nov 2008)
+*synce-librapi2-0.11.1 (13 Nov 2008)
+
+ 13 Nov 2008; Federico Ferri <mescalinum@gentoo.org>
+ +synce-librapi2-0.11.1.ebuild, +synce-librapi2-0.12.ebuild:
+ getting synce-0.12 into tree. ebuild coming from synce overlay, reviewed
+ and tested.
06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
synce-librapi2-0.9.1.ebuild:
diff --git a/app-pda/synce-librapi2/synce-librapi2-0.11.1.ebuild b/app-pda/synce-librapi2/synce-librapi2-0.11.1.ebuild
new file mode 100644
index 000000000000..c2c90a235a63
--- /dev/null
+++ b/app-pda/synce-librapi2/synce-librapi2-0.11.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librapi2/synce-librapi2-0.11.1.ebuild,v 1.1 2008/11/13 06:15:06 mescalinum Exp $
+
+DESCRIPTION="SynCE - RAPI communication library"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="dev-lang/python
+ dev-python/pyrex
+ >=dev-libs/check-0.8.2
+ ~app-pda/synce-libsynce-0.11.1"
+
+SRC_URI="mirror://sourceforge/synce/librapi2-${PV}.tar.gz"
+S="${WORKDIR}/librapi2-${PV}"
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc BUGS README README.contributing README.design TODO ChangeLog
+}
diff --git a/app-pda/synce-librapi2/synce-librapi2-0.12.ebuild b/app-pda/synce-librapi2/synce-librapi2-0.12.ebuild
new file mode 100644
index 000000000000..63da37528130
--- /dev/null
+++ b/app-pda/synce-librapi2/synce-librapi2-0.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librapi2/synce-librapi2-0.12.ebuild,v 1.1 2008/11/13 06:15:06 mescalinum Exp $
+
+inherit eutils
+
+DESCRIPTION="SynCE - RAPI communication library"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="dev-lang/python
+ dev-python/pyrex
+ >=dev-libs/check-0.8.2
+ ~app-pda/synce-libsynce-0.12"
+
+SRC_URI="mirror://sourceforge/synce/librapi2-${PV}.tar.gz"
+S="${WORKDIR}/librapi2-${PV}"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc BUGS README README.contributing README.design TODO ChangeLog
+}