summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-02-07 02:51:55 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-02-07 02:51:55 +0000
commitf4ecd6022a6b7820364117a57a3889c257bcbc86 (patch)
tree1d91fbab8418c6eaa5d09fa3d38232eb11b62fc3 /app-sci/xdrawchem/xdrawchem-1.6.3.ebuild
parentuse epatch and nls fix (diff)
downloadhistorical-f4ecd6022a6b7820364117a57a3889c257bcbc86.tar.gz
historical-f4ecd6022a6b7820364117a57a3889c257bcbc86.tar.bz2
historical-f4ecd6022a6b7820364117a57a3889c257bcbc86.zip
new version, works with qt-3.1
Diffstat (limited to 'app-sci/xdrawchem/xdrawchem-1.6.3.ebuild')
-rw-r--r--app-sci/xdrawchem/xdrawchem-1.6.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-sci/xdrawchem/xdrawchem-1.6.3.ebuild b/app-sci/xdrawchem/xdrawchem-1.6.3.ebuild
new file mode 100644
index 000000000000..5097f7e53179
--- /dev/null
+++ b/app-sci/xdrawchem/xdrawchem-1.6.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xdrawchem/xdrawchem-1.6.3.ebuild,v 1.1 2003/02/07 02:51:55 george Exp $
+
+IUSE="qt"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XDrawChem--a molecular structure drawing program."
+SRC_URI="http://www.prism.gatech.edu/~gte067k/${PN}/${P}.tgz"
+HOMEPAGE="http://www.prism.gatech.edu/~gte067k/${PN}"
+
+KEYWORDS="~x86 ~ppc ~sparc "
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="qt? ( >=qt-3.1.0 )"
+
+src_compile() {
+ ./configure --prefix=/usr || die
+ emake -f Makefile INSTRING=/usr/share/xdrawchem || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dobin xdrawchem/xdrawchem
+
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins ring/*
+
+ dodoc README.txt TODO.txt COPYRIGHT.txt HISTORY.txt
+}
+