summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2012-12-05 13:05:31 +0000
committerLars Wendler <polynomial-c@gentoo.org>2012-12-05 13:05:31 +0000
commit5736f5f9e1fe3a9b7a3238416e5c4e0b7e8766a6 (patch)
tree40737c944255d444451d3ae10504fa037d7210f1 /app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild
parentPlace vendor/escape.rb (diff)
downloadhistorical-5736f5f9e1fe3a9b7a3238416e5c4e0b7e8766a6.tar.gz
historical-5736f5f9e1fe3a9b7a3238416e5c4e0b7e8766a6.tar.bz2
historical-5736f5f9e1fe3a9b7a3238416e5c4e0b7e8766a6.zip
non-maintainer commit: Fixed installation of examples (bug #446086)
Package-Manager: portage-2.2.0_alpha144/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0x981CA6FC
Diffstat (limited to 'app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild')
-rw-r--r--app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild b/app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..f5ed938c80e4
--- /dev/null
+++ b/app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild,v 1.1 2012/12/05 13:05:28 polynomial-c Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A simple console menu program"
+HOMEPAGE="http://joeyh.name/code/pdmenu/"
+SRC_URI="mirror://debian/pool/main/p/pdmenu/pdmenu_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86"
+IUSE="nls gpm examples"
+
+DEPEND="
+ sys-libs/slang
+ gpm? ( sys-libs/gpm )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-impl-dec.patch
+ sed \
+ -e 's:\(-o pdmenu\):$(LDFLAGS) \1:g' \
+ -i Makefile || die
+}
+
+src_configure() {
+ econf \
+ $(use_with gpm) \
+ $(use_enable nls)
+}
+
+src_install() {
+ dobin pdmenu
+
+ dodoc doc/ANNOUNCE doc/BUGS doc/TODO
+
+ use examples && dodoc -r examples
+
+ mv doc/pdmenu.man doc/pdmenu.1
+ mv doc/pdmenurc.man doc/pdmenurc.5
+ doman doc/pdmenu.1 doc/pdmenurc.5
+
+}
+
+pkg_postinst() {
+ ewarn "Note this part from man page: Security warning! Any exec command"
+ ewarn "that uses the 'edit' flag will be a security hole. The user need"
+ ewarn "only to enter text with a ';' in it, and they can run an"
+ ewarn "arbitrary command after the semicolon!"
+}