summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-15 22:24:23 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-15 22:24:23 +0000
commita8f245f20711eb4df8bc613ba4668dc4b91e8f43 (patch)
treec41df2dce6fa17b3d0bb11ce2eb181e22042fe85 /app-shells
parentInitial bump. (diff)
downloadhistorical-a8f245f20711eb4df8bc613ba4668dc4b91e8f43.tar.gz
historical-a8f245f20711eb4df8bc613ba4668dc4b91e8f43.tar.bz2
historical-a8f245f20711eb4df8bc613ba4668dc4b91e8f43.zip
old
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-3.1_p5-r1.ebuild149
-rw-r--r--app-shells/bash/files/bash-3.1-arrays.patch45
-rw-r--r--app-shells/bash/files/digest-bash-3.1_p5-r17
3 files changed, 0 insertions, 201 deletions
diff --git a/app-shells/bash/bash-3.1_p5-r1.ebuild b/app-shells/bash/bash-3.1_p5-r1.ebuild
deleted file mode 100644
index 2f66554353a1..000000000000
--- a/app-shells/bash/bash-3.1_p5-r1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p5-r1.ebuild,v 1.1 2006/01/14 04:54:50 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-# Official patchlevel
-# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-READLINE_VER=5.1
-READLINE_PLEVEL=1
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-# Hit the GNU mirrors before hitting Chet's site
-SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
- ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
- $(for ((i=1; i<=PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- done)
- $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="afs nls build bashlogger unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
-
- # Include official patches
- local i
- for ((i=1; i<=PLEVEL; i++)); do
- epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
- done
- cd lib/readline
- for ((i=1; i<=READLINE_PLEVEL; i++)); do
- epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
- done
- epatch "${FILESDIR}"/readline-5.1-terminal-autowrap.patch #118205
- cd ../..
-
- # Fall back to /etc/inputrc
- epatch "${FILESDIR}"/${PN}-3.0-etc-inputrc.patch
- # Add more ulimit options (from Fedora)
- epatch "${FILESDIR}"/${MY_P}-ulimit.patch
- # Fix a memleak in read_builtin (from Fedora)
- epatch "${FILESDIR}"/${PN}-3.0-read-memleak.patch
- # Don't barf on handled signals in scripts
- epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
-# # Fix generation of signals list when cross-compiling
-# epatch "${FILESDIR}"/${PN}-3.0-cross-signals.patch
- # Log bash commands to syslog #91327
- if use bashlogger ; then
- echo
- ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
- ewarn "This will log ALL output you enter into the shell, you have been warned."
- ebeep
- epause
- epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
- fi
-
- epatch "${FILESDIR}"/${PN}-3.0-configs.patch
-
- sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
-}
-
-src_compile() {
- filter-flags -malign-double
-
- local myconf=
-
- # Always use the buildin readline, else if we update readline
- # bash gets borked as readline is usually not binary compadible
- # between minor versions.
- #myconf="${myconf} $(use_with !readline installed-readline)"
- myconf="${myconf} --without-installed-readline"
-
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to use with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf="${myconf} --disable-nls"
-
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses
- export bash_cv_termcap_lib=libcurses
- myconf="${myconf} --with-ncurses"
-
- econf \
- $(use_with afs) \
- --disable-profiling \
- --without-gnu-malloc \
- ${myconf} || die
- emake -j1 || die "make failed" # see bug 102426
-}
-
-src_install() {
- einstall || die
-
- dodir /bin
- mv "${D}"/usr/bin/bash "${D}"/bin/
- [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
- dosym bash /bin/rbash
-
- insinto /etc/bash
- doins "${FILESDIR}"/{bashrc,bash_logout}
- insinto /etc/skel
- for f in bash{_logout,_profile,rc} ; do
- newins "${FILESDIR}"/dot-${f} .${f}
- done
-
- if use build ; then
- rm -rf "${D}"/usr
- else
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
- dosym bash.info.gz /usr/share/info/bashref.info.gz
- fi
-}
-
-pkg_preinst() {
- if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
- mkdir -p "${ROOT}"/etc/bash
- mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
- fi
-
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-}
diff --git a/app-shells/bash/files/bash-3.1-arrays.patch b/app-shells/bash/files/bash-3.1-arrays.patch
deleted file mode 100644
index 6b1fc8f676b2..000000000000
--- a/app-shells/bash/files/bash-3.1-arrays.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2005-12/msg00062.html
-
-Date: Sat, 24 Dec 2005 13:27:55 -0500
-From: Chet Ramey <chet.ramey@case.edu>
-To: Mike Frysinger <vapier@gentoo.org>
-CC: bug-bash@gnu.org,
- chet@case.edu
-Subject: Re: bash-3.1.1 parses arrays slightly incorrectly
-
-Mike Frysinger wrote:
-> On Thu, Dec 22, 2005 at 09:24:06AM -0500, Chet Ramey wrote:
->> Bash-Release: 3.1
->> Patch-ID: bash31-001
->>
->> Bug-Description:
->>
->> There are parsing problems with compound assignments in several contexts,
->> including as arguments to builtins like `local', `eval', and `let', and
->> as multiple assignments in a single command.
->
-> still seems to be a slight regression here with arrays ...
-
-Try this:
-
-*** ../bash-3.1/subst.c Mon Oct 24 09:51:13 2005
---- subst.c Fri Dec 23 15:21:09 2005
-***************
-*** 2188,2192 ****
- {
- v = find_variable (name);
-! if (v == 0 || array_p (v) == 0)
- v = make_local_array_variable (name);
- v = assign_array_var_from_string (v, value, flags);
---- 2188,2192 ----
- {
- v = find_variable (name);
-! if (v == 0 || array_p (v) == 0 || v->context != variable_context)
- v = make_local_array_variable (name);
- v = assign_array_var_from_string (v, value, flags);
-
---
-``The lyf so short, the craft so long to lerne.'' - Chaucer
-( ``Discere est Dolere'' -- chet )
- Live Strong.
-Chet Ramey, ITS, CWRU chet@case.edu http://cnswww.cns.cwru.edu/~chet/
diff --git a/app-shells/bash/files/digest-bash-3.1_p5-r1 b/app-shells/bash/files/digest-bash-3.1_p5-r1
deleted file mode 100644
index f894d8d19a53..000000000000
--- a/app-shells/bash/files/digest-bash-3.1_p5-r1
+++ /dev/null
@@ -1,7 +0,0 @@
-MD5 ef5304c4b22aaa5088972c792ed45d72 bash-3.1.tar.gz 2533934
-MD5 c0d33bdfed6e4e6a9ae9200b77cd5c99 bash31-001 2708
-MD5 0c9be3bad344d04b79c4eac9eb39624c bash31-002 7169
-MD5 04750485f335972f7a980a1bfe048dba bash31-003 1324
-MD5 0c2856794ab16a4c224223c1964140c2 bash31-004 1470
-MD5 943233d7227071fa040c8b9eb016fa0c bash31-005 1322
-MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042