summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-08 19:52:55 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-08 19:52:55 +0000
commitb06c247f9fd0f9d5c04d1f09d7dd369b89944232 (patch)
tree6f9a07bf0d49958f921c5e4bfd6a014585d3f74e /app-shells
parentStable on sparc wrt #169461 (diff)
downloadhistorical-b06c247f9fd0f9d5c04d1f09d7dd369b89944232.tar.gz
historical-b06c247f9fd0f9d5c04d1f09d7dd369b89944232.tar.bz2
historical-b06c247f9fd0f9d5c04d1f09d7dd369b89944232.zip
move /bin/sh tweaking to pkg_preinst() so we dont break on upgrades
Package-Manager: portage-2.1.2.1-r1
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/Manifest14
-rw-r--r--app-shells/bash/bash-3.2_p10.ebuild6
2 files changed, 10 insertions, 10 deletions
diff --git a/app-shells/bash/Manifest b/app-shells/bash/Manifest
index f5d55217d98f..4cccaa99b3f6 100644
--- a/app-shells/bash/Manifest
+++ b/app-shells/bash/Manifest
@@ -285,10 +285,10 @@ EBUILD bash-3.1_p17.ebuild 4601 RMD160 7d674942ae8ebcb662faa45a9efacb236bd6202e
MD5 22830ce4e0c1e669719581d5e00cfb82 bash-3.1_p17.ebuild 4601
RMD160 7d674942ae8ebcb662faa45a9efacb236bd6202e bash-3.1_p17.ebuild 4601
SHA256 ff12913c0306b1b597fb7da13740af52c2ccd65125695914fcf84cac455681a8 bash-3.1_p17.ebuild 4601
-EBUILD bash-3.2_p10.ebuild 4378 RMD160 597105ec362899234ac0bcd3c291bf1ec04844b6 SHA1 836b3ecbb6767ee2258686ecf4afd3a8bbf8a72f SHA256 acf9fb75c14eb8e2599b98edceeb3acf8867be783699e80fec24cdb4af8ab736
-MD5 f1d75e5c3c6352556588d94d3aa3100e bash-3.2_p10.ebuild 4378
-RMD160 597105ec362899234ac0bcd3c291bf1ec04844b6 bash-3.2_p10.ebuild 4378
-SHA256 acf9fb75c14eb8e2599b98edceeb3acf8867be783699e80fec24cdb4af8ab736 bash-3.2_p10.ebuild 4378
+EBUILD bash-3.2_p10.ebuild 4402 RMD160 fbe2b604872008bf523266b50ab4f159971124ea SHA1 e8686c0ee52ab1d8203e59f79e8406c0ca9bb255 SHA256 9acdc3471174bae2f03787d2789ae39295595bb3df2632b2d2e56bd1cec9a2e8
+MD5 8708824c2262f4484f893ca481ac83c4 bash-3.2_p10.ebuild 4402
+RMD160 fbe2b604872008bf523266b50ab4f159971124ea bash-3.2_p10.ebuild 4402
+SHA256 9acdc3471174bae2f03787d2789ae39295595bb3df2632b2d2e56bd1cec9a2e8 bash-3.2_p10.ebuild 4402
EBUILD bash-3.2_p9-r1.ebuild 4340 RMD160 d663e053149393248d9ae8a194c5b4bf6d04f794 SHA1 db7f1abd2839e01d542d44f795b934b57db86c2d SHA256 21e4785d3630607b051feed27c8f2c8fd0e8dc62305a66938bcee52979c370aa
MD5 2ddfec75db6f094863e533d055719767 bash-3.2_p9-r1.ebuild 4340
RMD160 d663e053149393248d9ae8a194c5b4bf6d04f794 bash-3.2_p9-r1.ebuild 4340
@@ -325,7 +325,7 @@ SHA256 1fe387fc344fd77f445608d6e5d99d8547c8c2f0aba4150c6b54720ff7a0b7df files/di
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.2 (GNU/Linux)
-iD8DBQFF8D/p8bi6rjpTunYRAj9nAKChr3esGddF0mKmQPgWKulj357HBgCgq2Gi
-cxsedQT/lVqM+q9oEVzegn0=
-=qbNY
+iD8DBQFF8Gmy8bi6rjpTunYRAkhAAKDE5LEwpn4zYMNlFW5BOOb3gh5tHgCfZBiI
+OhOEvz97N7agP81DpzO3lbA=
+=RtN1
-----END PGP SIGNATURE-----
diff --git a/app-shells/bash/bash-3.2_p10.ebuild b/app-shells/bash/bash-3.2_p10.ebuild
index 7792f9f80a3e..3dc4727ddcd6 100644
--- a/app-shells/bash/bash-3.2_p10.ebuild
+++ b/app-shells/bash/bash-3.2_p10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p10.ebuild,v 1.2 2007/03/08 16:54:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p10.ebuild,v 1.3 2007/03/08 19:52:55 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -140,10 +140,10 @@ pkg_preinst() {
if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
rm -f "${D}"/etc/bash/bash_logout
fi
-}
-pkg_postinst() {
if [[ ! -e ${ROOT}/bin/sh ]] ; then
ln -s bash "${ROOT}"/bin/sh
+ else
+ cp -a "${ROOT}"/bin/sh "${D}"/bin/
fi
}