summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-08-18 19:18:39 +0000
committerNed Ludd <solar@gentoo.org>2004-08-18 19:18:39 +0000
commiteceadf15b071305c08aecda16e707e231e7207a3 (patch)
treec962a10edfbb6dc88204c8e110312248dcf8ace5 /app-text/aspell/aspell-0.50.5-r4.ebuild
parentRemove patch since Rakshasa upgraded the package with its changes. (diff)
downloadhistorical-eceadf15b071305c08aecda16e707e231e7207a3.tar.gz
historical-eceadf15b071305c08aecda16e707e231e7207a3.tar.bz2
historical-eceadf15b071305c08aecda16e707e231e7207a3.zip
slight update to charcount patch for bug #53389
Diffstat (limited to 'app-text/aspell/aspell-0.50.5-r4.ebuild')
-rw-r--r--app-text/aspell/aspell-0.50.5-r4.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/app-text/aspell/aspell-0.50.5-r4.ebuild b/app-text/aspell/aspell-0.50.5-r4.ebuild
new file mode 100644
index 000000000000..5caf650b283f
--- /dev/null
+++ b/app-text/aspell/aspell-0.50.5-r4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5-r4.ebuild,v 1.1 2004/08/18 19:18:39 solar Exp $
+
+inherit libtool eutils flag-o-matic
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ppc64"
+IUSE="gpm"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
+
+pkg_setup() {
+ if [ ${ARCH} = "ppc" ] ; then
+ CXXFLAGS="-O2 -fsigned-char"
+ CFLAGS=${CXXFLAGS}
+ fi
+ use gpm && append-ldflags -lgpm
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-0.50.5-charcount.patch
+ epatch ${FILESDIR}/${PN}-quotechar-fix.patch
+}
+
+src_compile() {
+ filter-flags -fno-rtti
+ elibtoolize --reverse-deps
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ dodoc README* TODO
+
+ make DESTDIR=${D} install || die
+ mv ${D}/usr/share/doc/${PF}/man-html ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/man-text ${D}/usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc ${S}/examples/*
+
+}
+
+pkg_postinst() {
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-dicts category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+
+ ewarn ""
+ ewarn "Please re-emerge ALL your aspell-LANG dictionaries"
+ ewarn ""
+ for TICKER in 1 2 3 4 5; do
+ # Double beep here.
+ echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
+ echo -ne "\a" ; sleep 1
+ done
+}