summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2010-04-06 16:09:36 +0000
committerJonathan Callen <jcallen@gentoo.org>2010-04-06 16:09:36 +0000
commitdf1027fa935093cbf862c1be52d63bd4eaa48eb2 (patch)
tree2bb15d018d7a34bc2b809b1c9ba39d78e3f0f0bf /app-text/aspell/aspell-0.60.6-r1.ebuild
parentDisable maintainer-mode since it enables DISABLE_DEPRECATED macros, which may... (diff)
downloadhistorical-df1027fa935093cbf862c1be52d63bd4eaa48eb2.tar.gz
historical-df1027fa935093cbf862c1be52d63bd4eaa48eb2.tar.bz2
historical-df1027fa935093cbf862c1be52d63bd4eaa48eb2.zip
Bump to EAPI=3, add prefix keywords, patches
Package-Manager: portage--svn/cvs/Linux i686
Diffstat (limited to 'app-text/aspell/aspell-0.60.6-r1.ebuild')
-rw-r--r--app-text/aspell/aspell-0.60.6-r1.ebuild38
1 files changed, 20 insertions, 18 deletions
diff --git a/app-text/aspell/aspell-0.60.6-r1.ebuild b/app-text/aspell/aspell-0.60.6-r1.ebuild
index a78bc7f37fba..0328c0e8ef89 100644
--- a/app-text/aspell/aspell-0.60.6-r1.ebuild
+++ b/app-text/aspell/aspell-0.60.6-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.6-r1.ebuild,v 1.9 2010/04/05 21:03:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.6-r1.ebuild,v 1.10 2010/04/06 16:09:36 abcd Exp $
+
+EAPI="3"
# N.B. This is before inherit of autotools, as autotools.eclass adds the
# relevant dependencies to DEPEND.
@@ -14,7 +16,7 @@ SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="nls examples"
# Note; app-text/aspell-0.6 and app-dicts/aspell-en-0.6 must go stable together
@@ -39,26 +41,28 @@ done
PDEPEND="${PDEPEND}
${def}"
-RDEPEND=">=sys-libs/ncurses-5.2
- nls? ( virtual/libintl )
- !=app-dicts/aspell-en-0.5*"
-# English dictionary 0.5 is incompatible with aspell-0.6
+COMMON_DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/aspell-0.60.3-templateinstantiations.patch"
+# English dictionary 0.5 is incompatible with aspell-0.6
+RDEPEND="${COMMON_DEPEND}
+ !=app-dicts/aspell-en-0.5*"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.60.3-templateinstantiations.patch"
epatch "${FILESDIR}/${PN}-0.60.5-nls.patch"
+ epatch "${FILESDIR}/${PN}-0.60.5-solaris.patch"
+ epatch "${FILESDIR}/${P}-darwin-bundles.patch"
rm m4/lt* m4/libtool.m4
eautoreconf
elibtoolize --reverse-deps
}
-src_compile() {
+src_configure() {
filter-flags -fno-rtti
filter-flags -fvisibility=hidden #77109
filter-flags -maltivec -mabi=altivec
@@ -72,18 +76,16 @@ src_compile() {
LIBS="${mylibs}" econf \
$(use_enable nls) \
--disable-static \
- --sysconfdir=/etc/aspell \
- --enable-docdir=/usr/share/doc/${PF}
-
- emake || die "compilation failed"
+ --sysconfdir="${EPREFIX}"/etc/aspell \
+ --enable-docdir="${EPREFIX}"/usr/share/doc/${PF}
}
src_install() {
dodoc README* TODO || die "installing docs failed"
emake DESTDIR="${D}" install || die "installation failed"
- mv "${D}"/usr/share/doc/${PF}/man-html "${D}"/usr/share/doc/${PF}/html
- mv "${D}"/usr/share/doc/${PF}/man-text "${D}"/usr/share/doc/${PF}/text
+ mv "${ED}"usr/share/doc/${PF}/man-html "${ED}"usr/share/doc/${PF}/html
+ mv "${ED}"usr/share/doc/${PF}/man-text "${ED}"usr/share/doc/${PF}/text
# install ispell/aspell compatibility scripts
exeinto /usr/bin