summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-09-06 00:57:37 +0000
committerMichael Weber <xmw@gentoo.org>2010-09-06 00:57:37 +0000
commitcceea2734ddfdbf7305a53db52a8710a12f9893d (patch)
treee48da1ae7842a7ea5b8039d0d22fdf5c4df07d9d /app-text/barcode/barcode-0.98-r1.ebuild
parentVersion bump to fix bug #326941 (diff)
downloadhistorical-cceea2734ddfdbf7305a53db52a8710a12f9893d.tar.gz
historical-cceea2734ddfdbf7305a53db52a8710a12f9893d.tar.bz2
historical-cceea2734ddfdbf7305a53db52a8710a12f9893d.zip
Revbump to fix LDFLAGS from bug #335631.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'app-text/barcode/barcode-0.98-r1.ebuild')
-rw-r--r--app-text/barcode/barcode-0.98-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/barcode/barcode-0.98-r1.ebuild b/app-text/barcode/barcode-0.98-r1.ebuild
new file mode 100644
index 000000000000..052968bedc88
--- /dev/null
+++ b/app-text/barcode/barcode-0.98-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/barcode/barcode-0.98-r1.ebuild,v 1.1 2010/09/06 00:57:37 xmw Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="barcode generator"
+HOMEPAGE="http://www.gnu.org/software/barcode/"
+SRC_URI="mirror://gnu/barcode/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-info.patch
+ sed -i -e '/^LDFLAGS =/s:=:+=:' \
+ -e "/^aLIBDIR/s:lib:$(get_libdir):" \
+ -e '/^INFODIR/s:info:share/info:' \
+ -e '/^MAN/s:man:share/man:' \
+ Makefile.in || die
+}
+
+src_configure() {
+ tc-export CC
+ econf
+}
+
+src_install() {
+ emake install prefix="${ED}/usr" || die
+ dodoc ChangeLog README TODO doc/barcode.{pdf,ps} || die
+}