summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-03-27 21:57:38 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-03-27 21:57:38 +0000
commit6b21769613777d5f2daaec5e1692788465ed78a9 (patch)
tree967665caab31e6a2e0e6011e2bf7095051abf211 /app-text/dos2unix
parentFix code to be compatible with x11-libs/libnotify >= 0.7 API. Introduce saved... (diff)
downloadhistorical-6b21769613777d5f2daaec5e1692788465ed78a9.tar.gz
historical-6b21769613777d5f2daaec5e1692788465ed78a9.tar.bz2
historical-6b21769613777d5f2daaec5e1692788465ed78a9.zip
remove old ebuilds
Package-Manager: portage-2.1.9.44/cvs/Linux x86_64
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/ChangeLog6
-rw-r--r--app-text/dos2unix/dos2unix-5.1.ebuild53
-rw-r--r--app-text/dos2unix/dos2unix-5.2.ebuild56
3 files changed, 5 insertions, 110 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index 837e9ba688d1..9580156eaa18 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.65 2011/03/20 08:19:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.66 2011/03/27 21:55:05 darkside Exp $
+
+ 27 Mar 2011; Jeremy Olexa <darkside@gentoo.org> -dos2unix-5.1.ebuild,
+ -dos2unix-5.2.ebuild:
+ remove old ebuilds
20 Mar 2011; Justin Lecher <jlec@gentoo.org> dos2unix-5.1.ebuild,
dos2unix-5.1.1.ebuild, dos2unix-5.2.ebuild, dos2unix-5.2.1.ebuild:
diff --git a/app-text/dos2unix/dos2unix-5.1.ebuild b/app-text/dos2unix/dos2unix-5.1.ebuild
deleted file mode 100644
index 9c1feb682757..000000000000
--- a/app-text/dos2unix/dos2unix-5.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.1.ebuild,v 1.10 2011/03/20 08:19:15 jlec Exp $
-
-EAPI="3"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
-HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
-SRC_URI="
- http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
- mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
-IUSE="nls"
-
-RDEPEND="
- !app-text/hd2u
- !app-text/unix2dos
- virtual/libintl"
-DEPEND="
- ${RDEPEND}
- dev-lang/perl"
-
-src_prepare() {
- sed \
- -e '/^LDFLAGS/s|=|+=|' \
- -e '/^CC/s|=|?=|' \
- -e '/CFLAGS_OS \+=/d' \
- -e '/LDFLAGS_EXTRA \+=/d' \
- -i "${S}"/Makefile || die
- tc-export CC
-}
-
-lintl() {
- # same logic as from virtual/libintl
- use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
-}
-
-src_compile() {
- emake prefix="${EPREFIX}/usr" \
- $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=") \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
- $(use nls || echo "ENABLE_NLS=") install \
- || die "emake install failed"
-}
diff --git a/app-text/dos2unix/dos2unix-5.2.ebuild b/app-text/dos2unix/dos2unix-5.2.ebuild
deleted file mode 100644
index 96a0886e1f68..000000000000
--- a/app-text/dos2unix/dos2unix-5.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.2.ebuild,v 1.4 2011/03/20 08:19:15 jlec Exp $
-
-EAPI="3"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
-HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
-SRC_URI="
- http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
- mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
-IUSE="nls"
-
-RDEPEND="
- !app-text/hd2u
- !app-text/unix2dos
- virtual/libintl"
-DEPEND="
- ${RDEPEND}
- dev-lang/perl"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-5.2-makefile.patch
-
- sed \
- -e '/^LDFLAGS/s|=|+=|' \
- -e '/^CC/s|=|?=|' \
- -e '/CFLAGS_OS \+=/d' \
- -e '/LDFLAGS_EXTRA \+=/d' \
- -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
- -i "${S}"/Makefile || die
- tc-export CC
-}
-
-lintl() {
- # same logic as from virtual/libintl
- use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
-}
-
-src_compile() {
- emake prefix="${EPREFIX}/usr" \
- $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=") \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
- $(use nls || echo "ENABLE_NLS=") install \
- || die "emake install failed"
-}