summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-09-12 07:20:19 +0000
committerMatthew Turk <satai@gentoo.org>2002-09-12 07:20:19 +0000
commitdbf1205104f11920b1447bb4401d807037e0fc11 (patch)
tree2cf11b268e20ee41a596639e4b028e411b45e677 /app-text/gentoo-guide-xml-dtd/gentoo-guide-xml-dtd-2.1.ebuild
parentadded keywords (diff)
downloadhistorical-dbf1205104f11920b1447bb4401d807037e0fc11.tar.gz
historical-dbf1205104f11920b1447bb4401d807037e0fc11.tar.bz2
historical-dbf1205104f11920b1447bb4401d807037e0fc11.zip
Added much more robust file checking to several of these; hopefully this will
clear up any outstanding issues with sgml catalogs. This should also fix the behavior seen in bug 6854.
Diffstat (limited to 'app-text/gentoo-guide-xml-dtd/gentoo-guide-xml-dtd-2.1.ebuild')
-rw-r--r--app-text/gentoo-guide-xml-dtd/gentoo-guide-xml-dtd-2.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-text/gentoo-guide-xml-dtd/gentoo-guide-xml-dtd-2.1.ebuild b/app-text/gentoo-guide-xml-dtd/gentoo-guide-xml-dtd-2.1.ebuild
index 1db9272abf38..be354be83ba8 100644
--- a/app-text/gentoo-guide-xml-dtd/gentoo-guide-xml-dtd-2.1.ebuild
+++ b/app-text/gentoo-guide-xml-dtd/gentoo-guide-xml-dtd-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/gentoo-guide-xml-dtd/gentoo-guide-xml-dtd-2.1.ebuild,v 1.7 2002/08/16 02:42:01 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gentoo-guide-xml-dtd/gentoo-guide-xml-dtd-2.1.ebuild,v 1.8 2002/09/12 07:20:19 satai Exp $
S=${WORKDIR}
DESCRIPTION="DTD for Gentoo-Guide Style XML Files"
@@ -30,5 +30,8 @@ pkg_postinst() {
}
pkg_prerm() {
- install-catalog --remove /etc/sgml/gentoo-guide.cat /usr/share/sgml/guide/catalog
+ if [ -e /etc/sgml/gentoo-guide.cat ]
+ then
+ install-catalog --remove /etc/sgml/gentoo-guide.cat /usr/share/sgml/guide/catalog
+ fi
}