summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-25 13:01:56 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-25 13:01:56 +0000
commit7f5e7dfb8eabcead51bb0c2f0803937437e45a6f (patch)
treea5faec0d0ea42122b9840d32d45ea2de2e047fd9 /app-text/ggv
parent*** empty log message *** (diff)
downloadhistorical-7f5e7dfb8eabcead51bb0c2f0803937437e45a6f.tar.gz
historical-7f5e7dfb8eabcead51bb0c2f0803937437e45a6f.tar.bz2
historical-7f5e7dfb8eabcead51bb0c2f0803937437e45a6f.zip
*** empty log message ***
Diffstat (limited to 'app-text/ggv')
-rw-r--r--app-text/ggv/files/digest-ggv-0.95-r11
-rw-r--r--app-text/ggv/ggv-0.95-r1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-text/ggv/files/digest-ggv-0.95-r1 b/app-text/ggv/files/digest-ggv-0.95-r1
new file mode 100644
index 000000000000..25576b9bc48a
--- /dev/null
+++ b/app-text/ggv/files/digest-ggv-0.95-r1
@@ -0,0 +1 @@
+MD5 e407836a107279b8fda1b961539a1cff ggv-0.95.tar.gz
diff --git a/app-text/ggv/ggv-0.95-r1.ebuild b/app-text/ggv/ggv-0.95-r1.ebuild
new file mode 100644
index 000000000000..11ac5594001f
--- /dev/null
+++ b/app-text/ggv/ggv-0.95-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ggv-0.95-r1.ebuild,v 1.1 2000/11/25 13:01:56 achim Exp $
+
+P=ggv-0.95
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Ghostview"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=app-text/ghostscript-6.23
+ >=gnome-base/gnome-libs-1.2.4
+ || ( >=net-print/LPRng-3.6.24 >=net-print/cups-1.1.3 )"
+
+src_compile() {
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s/BONOBO_TRUE/BONOBO_FALSE/" configure.orig > configure
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --without-bonobo
+ # bonobo support does not work yet
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+
+}
+
+
+
+