summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-08 10:25:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-08 10:25:36 +0000
commitf3fcd3fcad3bf127a1c824af713c923976092650 (patch)
tree83a6a7165b5c06610a166278ffdd8e253067d1e5 /app-text/ghostscript-gpl/ghostscript-gpl-8.71-r1.ebuild
parent*portage-2.2_rc66 (08 Mar 2010) (diff)
downloadhistorical-f3fcd3fcad3bf127a1c824af713c923976092650.tar.gz
historical-f3fcd3fcad3bf127a1c824af713c923976092650.tar.bz2
historical-f3fcd3fcad3bf127a1c824af713c923976092650.zip
Fix libpng14 detection wrt #305111 by Lars Wendler.
Package-Manager: portage-2.2_rc65/cvs/Linux x86_64
Diffstat (limited to 'app-text/ghostscript-gpl/ghostscript-gpl-8.71-r1.ebuild')
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-8.71-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-8.71-r1.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-8.71-r1.ebuild
index 9107d6e7efa8..55a630c448f4 100644
--- a/app-text/ghostscript-gpl/ghostscript-gpl-8.71-r1.ebuild
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-8.71-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ghostscript-gpl-8.71-r1.ebuild,v 1.1 2010/03/07 17:08:03 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ghostscript-gpl-8.71-r1.ebuild,v 1.2 2010/03/08 10:25:36 ssuominen Exp $
inherit autotools eutils versionator flag-o-matic
@@ -114,9 +114,19 @@ src_unpack() {
-e "s:GS_DOCDIR=.*:GS_DOCDIR=/usr/share/doc/${PF}/html:" \
base/Makefile.in base/*.mak || die "sed failed"
+ # http://repos.archlinux.org/wsvn/packages/ghostscript/trunk/libpng14.patch
+ if has_version ">=media-libs/libpng-1.4"; then
+ sed -i \
+ -e 's:png_check_sig:png_sig_cmp:' \
+ "${S}"/{,base,jbig2dec}/configure.ac || die
+ fi
+
cd "${S}"
eautoreconf
+ cd "${S}/jbig2dec"
+ eautoreconf
+
cd "${S}/ijs"
eautoreconf
}