summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-06-05 19:05:35 +0000
committerMamoru Komachi <usata@gentoo.org>2004-06-05 19:05:35 +0000
commit1c724000b9e467edba22b5131d55f3c6d73cc7df (patch)
treec537bbe4d4fb831d7a30877aca9ca9615b1b20b6 /app-text/html2text/html2text-1.3.2.ebuild
parentnew version on cpan (diff)
downloadhistorical-1c724000b9e467edba22b5131d55f3c6d73cc7df.tar.gz
historical-1c724000b9e467edba22b5131d55f3c6d73cc7df.tar.bz2
historical-1c724000b9e467edba22b5131d55f3c6d73cc7df.zip
Version bumped. Updated source file location for 1.3.1. Thanks to mll <mlleinin@pacbell.net>, closing bug #52643
Diffstat (limited to 'app-text/html2text/html2text-1.3.2.ebuild')
-rw-r--r--app-text/html2text/html2text-1.3.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/html2text/html2text-1.3.2.ebuild b/app-text/html2text/html2text-1.3.2.ebuild
new file mode 100644
index 000000000000..579d50db6878
--- /dev/null
+++ b/app-text/html2text/html2text-1.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/html2text/html2text-1.3.2.ebuild,v 1.1 2004/06/05 19:05:35 usata Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="A HTML to text converter"
+HOMEPAGE="http://userpage.fu-berlin.de/~mbayer/tools/html2text.html"
+SRC_URI="http://userpage.fu-berlin.de/~mbayer/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64"
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if [ `gcc-major-version` -ge 3 -a `gcc-minor-version` -ge 3 ]
+ then
+ epatch 1.3.2_to_1.3.2a.diff
+ fi
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dobin html2text
+ doman html2text.1.gz
+ doman html2textrc.5.gz
+ dodoc CHANGES CREDITS INSTALL KNOWN_BUGS README TODO
+}