summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2008-03-27 16:03:46 +0000
committerFerris McCormick <fmccor@gentoo.org>2008-03-27 16:03:46 +0000
commiteb9e1db3bdf4dcef46b0529927769bb6d3d481b3 (patch)
tree334da61d81ddbb6472a11c496f53343218ca1377 /app-text/pep/pep-2.8.ebuild
parentStable on ppc64; bug #214975 (diff)
downloadhistorical-eb9e1db3bdf4dcef46b0529927769bb6d3d481b3.tar.gz
historical-eb9e1db3bdf4dcef46b0529927769bb6d3d481b3.tar.bz2
historical-eb9e1db3bdf4dcef46b0529927769bb6d3d481b3.zip
Syntax cleanup, suggested by Tiago Cunha on Bug #215011. Please see ChangeLog or the Bug.
Package-Manager: portage-2.2_pre5
Diffstat (limited to 'app-text/pep/pep-2.8.ebuild')
-rw-r--r--app-text/pep/pep-2.8.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-text/pep/pep-2.8.ebuild b/app-text/pep/pep-2.8.ebuild
index 8e87080653f7..6e2c126f41c0 100644
--- a/app-text/pep/pep-2.8.ebuild
+++ b/app-text/pep/pep-2.8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pep/pep-2.8.ebuild,v 1.10 2008/03/27 14:03:32 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pep/pep-2.8.ebuild,v 1.11 2008/03/27 16:03:46 fmccor Exp $
-inherit eutils
+inherit eutils toolchain-funcs
-DESCRIPTION="Pep is a general purpose filter and file cleaning program"
+DESCRIPTION="General purpose filter and file cleaning program"
HOMEPAGE="http://folk.uio.no/gisle/enjoy/pep.html"
SRC_URI="http://folk.uio.no/gisle/enjoy/${PN}${PV//./}.zip"
@@ -13,9 +13,8 @@ SLOT="0"
KEYWORDS="mips ppc sparc x86"
IUSE=""
-DEPEND="app-arch/unzip
- virtual/libc"
-RDEPEND="virtual/libc"
+DEPEND="app-arch/unzip"
+RDEPEND=""
S=${WORKDIR}
@@ -23,17 +22,17 @@ src_unpack() {
unpack ${A}
# pep does not come with autconf so here's a patch to configure
# Makefile with the correct path
- epatch ${FILESDIR}/${P}-gentoo.patch || die "epatch failed"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}
src_compile() {
# make man page too
make Doc/pep.1 || die "make man page failed"
- emake || die "emake failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install() {
- dobin pep || die
+ dobin pep
doman Doc/pep.1
insinto /usr/share/pep