summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-05 16:35:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-05 16:35:09 +0000
commit2ba2090883ce8d755f31773978cc39ad2619f234 (patch)
tree20e4f0b30fe810fd886ce82b0b63e6df10c4eeec /app-text/pytextile/pytextile-2.1.4.ebuild
parentVersion bumped. No longer exclude /etc/udev/rules.d from config_protect. (diff)
downloadhistorical-2ba2090883ce8d755f31773978cc39ad2619f234.tar.gz
historical-2ba2090883ce8d755f31773978cc39ad2619f234.tar.bz2
historical-2ba2090883ce8d755f31773978cc39ad2619f234.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-14926-svn/cvs/Linux x86_64
Diffstat (limited to 'app-text/pytextile/pytextile-2.1.4.ebuild')
-rw-r--r--app-text/pytextile/pytextile-2.1.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/pytextile/pytextile-2.1.4.ebuild b/app-text/pytextile/pytextile-2.1.4.ebuild
new file mode 100644
index 000000000000..370a7dc4b815
--- /dev/null
+++ b/app-text/pytextile/pytextile-2.1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/pytextile-2.1.4.ebuild,v 1.1 2009/12/05 16:35:09 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+NEED_PYTHON="2.5"
+
+inherit distutils
+
+MY_PN="textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python implementation of Textile, Dean Allen's Human Text Generator. Textile simplifies the work of creating (X)HTML."
+HOMEPAGE="http://pypi.python.org/pypi/textile"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}