summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-22 23:28:20 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-22 23:28:20 +0000
commitb1a7ea886838a10f23fca9ec6176ddef08390b67 (patch)
tree89dbb683ac9084cda6ab3a32405a5f4887bfa81a /app-text/rfcutil
parentremove baselayout (diff)
downloadhistorical-b1a7ea886838a10f23fca9ec6176ddef08390b67.tar.gz
historical-b1a7ea886838a10f23fca9ec6176ddef08390b67.tar.bz2
historical-b1a7ea886838a10f23fca9ec6176ddef08390b67.zip
clean up ebuild to not be a pos and add amd64 KEYWORDS
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-text/rfcutil')
-rw-r--r--app-text/rfcutil/Manifest14
-rw-r--r--app-text/rfcutil/rfcutil-3.2.3.ebuild32
2 files changed, 15 insertions, 31 deletions
diff --git a/app-text/rfcutil/Manifest b/app-text/rfcutil/Manifest
index 96aee682cce8..8a49e1648135 100644
--- a/app-text/rfcutil/Manifest
+++ b/app-text/rfcutil/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 3f68663275b07749c660181659feff2c rfcutil-3.2.3.ebuild 1312
MD5 64e5136bd95106df9498371fe25f6ad2 ChangeLog 1764
+MD5 c9b251e59c1f69b998d5b592e1444348 rfcutil-3.2.3.ebuild 1065
MD5 ab5b1af445d492d26a576f3f2e8204c3 metadata.xml 336
-MD5 93feedf0b8940d11c9662ebc22dec752 files/rfc-3.2.3.diff 840
MD5 da1829ff508f6abe3d77c2e87e8599bf files/digest-rfcutil-3.2.3 60
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCNwtHI1lqEGTUzyQRAjj2AJ9wYx61EsqfK06/7cW0+2pza/FOsACfXuui
-Fg60nr7TEV791lxGZgUc8j0=
-=CKdR
------END PGP SIGNATURE-----
+MD5 93feedf0b8940d11c9662ebc22dec752 files/rfc-3.2.3.diff 840
diff --git a/app-text/rfcutil/rfcutil-3.2.3.ebuild b/app-text/rfcutil/rfcutil-3.2.3.ebuild
index b135825b94a7..c4f716a7f98d 100644
--- a/app-text/rfcutil/rfcutil-3.2.3.ebuild
+++ b/app-text/rfcutil/rfcutil-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/rfcutil-3.2.3.ebuild,v 1.21 2005/03/15 14:15:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/rfcutil-3.2.3.ebuild,v 1.22 2005/04/22 23:28:20 vapier Exp $
inherit eutils
@@ -8,45 +8,39 @@ MY_PN="rfc"
MY_P="${MY_PN}-${PV}"
S="${WORKDIR}/${MY_P}"
-DESCRIPTION="RFC Util allows you to specify the number of an RFC, or a search
-string, and it returns all related RFCs. It features command line switches to
-spawn lynx or w3m to view the RFC, dump to file for offline viewing, or mail to
-an address. It also allows local and remote lookups of port, service, or proto
-numbers."
+DESCRIPTION="return all related RFCs based upon a number or a search string"
HOMEPAGE="http://www.dewn.com/rfc/"
SRC_URI="http://www.dewn.com/rfc/${MY_P}.tar.gz"
-IUSE=""
-KEYWORDS="x86 sparc ppc ~mips ppc64 ~alpha ppc-macos"
-SLOT="0"
+
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~mips ppc ppc64 ppc-macos sparc x86"
+IUSE=""
RDEPEND="dev-lang/perl
|| ( www-client/lynx virtual/w3m )"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${MY_P}.diff || die
-}
-
-src_compile() {
- einfo "Nothing to compile"
+ epatch "${FILESDIR}"/${MY_P}.diff
}
-src_install () {
- newbin ${MY_P} ${MY_PN}
+src_install() {
+ newbin ${MY_P} ${MY_PN} || die
doman ${MY_PN}.1
dodoc CHANGELOG INSTALL KNOWN_BUGS README
keepdir /var/cache/rfc
}
-pkg_postinst () {
+pkg_postinst() {
+ [[ ${ROOT} != "/" ]] && return 0
einfo "Generating rfc-index"
/usr/bin/rfc -i
einfo "Gaarde suggests you make a cron.monthly to run the following:"
einfo " /usr/bin/rfc -i"
}
-pkg_prerm () {
- rm /var/cache/rfc/* -f
+pkg_prerm() {
+ rm -f "${ROOT}"/var/cache/rfc/*
}