summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-01-07 11:33:13 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-01-07 11:33:13 +0000
commit506c38132eaa92fde92deb19c22e3e37a1454ced (patch)
tree41d4c44c549b7c6f8a1a1df2d127f023c495b2e8 /app-text/unrtf
parentFix libtool version mismatch for bug 74642. (diff)
downloadhistorical-506c38132eaa92fde92deb19c22e3e37a1454ced.tar.gz
historical-506c38132eaa92fde92deb19c22e3e37a1454ced.tar.bz2
historical-506c38132eaa92fde92deb19c22e3e37a1454ced.zip
Bug #74480, security fix.
Diffstat (limited to 'app-text/unrtf')
-rw-r--r--app-text/unrtf/ChangeLog8
-rw-r--r--app-text/unrtf/Manifest5
-rw-r--r--app-text/unrtf/files/digest-unrtf-0.19.3-r11
-rw-r--r--app-text/unrtf/files/unrtf-0.19.3-final.patch12
-rw-r--r--app-text/unrtf/unrtf-0.19.3-r1.ebuild33
5 files changed, 57 insertions, 2 deletions
diff --git a/app-text/unrtf/ChangeLog b/app-text/unrtf/ChangeLog
index 2c0ceb0c2409..759b9c524f04 100644
--- a/app-text/unrtf/ChangeLog
+++ b/app-text/unrtf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/unrtf
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unrtf/ChangeLog,v 1.12 2005/01/01 16:40:38 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/unrtf/ChangeLog,v 1.13 2005/01/07 11:33:12 robbat2 Exp $
+
+*unrtf-0.19.3-r1 (07 Jan 2005)
+
+ 07 Jan 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +files/unrtf-0.19.3-final.patch, +unrtf-0.19.3-r1.ebuild:
+ Bug #74480, security fix.
24 Sep 2004; Jodok Batlogg <batlogg@gentoo.org>; unrtf-0.19.3.ebuild:
marked as stable on ppc
diff --git a/app-text/unrtf/Manifest b/app-text/unrtf/Manifest
index 06448bfff9a7..4763f8b32449 100644
--- a/app-text/unrtf/Manifest
+++ b/app-text/unrtf/Manifest
@@ -1,5 +1,8 @@
-MD5 6708e39c4b5df9febab1043d667d7b55 ChangeLog 1455
MD5 e7cbe516f74ff70452647bbc80c2f44a unrtf-0.19.0.ebuild 588
+MD5 f5c7554b2b5c2b2e48fc0f374e475a1a unrtf-0.19.3-r1.ebuild 779
+MD5 513e95538f9e288225cc41c47ddcf43e ChangeLog 1626
MD5 a9076d6d799f48a3abb93afbf1078b81 unrtf-0.19.3.ebuild 609
+MD5 0bff1bbb720e0c045824f4f5a9c6142f files/unrtf-0.19.3-final.patch 400
MD5 245d5556f9662ad25f3ed5ec6a46ac51 files/digest-unrtf-0.19.0 64
MD5 14997a36fb2ed241ea9a7af11c590f4c files/digest-unrtf-0.19.3 64
+MD5 14997a36fb2ed241ea9a7af11c590f4c files/digest-unrtf-0.19.3-r1 64
diff --git a/app-text/unrtf/files/digest-unrtf-0.19.3-r1 b/app-text/unrtf/files/digest-unrtf-0.19.3-r1
new file mode 100644
index 000000000000..3c35abd2beec
--- /dev/null
+++ b/app-text/unrtf/files/digest-unrtf-0.19.3-r1
@@ -0,0 +1 @@
+MD5 e7eedca559efd94baf6f9541d7510a9b unrtf-0.19.3.tar.gz 127770
diff --git a/app-text/unrtf/files/unrtf-0.19.3-final.patch b/app-text/unrtf/files/unrtf-0.19.3-final.patch
new file mode 100644
index 000000000000..5e969fdf6b80
--- /dev/null
+++ b/app-text/unrtf/files/unrtf-0.19.3-final.patch
@@ -0,0 +1,12 @@
+diff -ur unrtf-0.19.3/convert.c.old unrtf-0.19.3/convert.c
+--- unrtf-0.19.3/convert.c.old 2004-12-25 21:08:41.000000000 -0500
++++ unrtf-0.19.3/convert.c 2004-12-25 20:40:26.000000000 -0500
+@@ -341,7 +341,7 @@
+ while(w2) {
+ tmp = word_string (w2);
+ if (tmp && tmp[0] != '\\')
+- strcat(name,tmp);
++ strncat(name,tmp,sizeof(name) - strlen(name) - 1);
+
+ w2=w2->next;
+ }
diff --git a/app-text/unrtf/unrtf-0.19.3-r1.ebuild b/app-text/unrtf/unrtf-0.19.3-r1.ebuild
new file mode 100644
index 000000000000..aa30aa03f968
--- /dev/null
+++ b/app-text/unrtf/unrtf-0.19.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/unrtf/unrtf-0.19.3-r1.ebuild,v 1.1 2005/01/07 11:33:12 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Converts RTF files to various formats"
+HOMEPAGE="http://www.gnu.org/software/unrtf/unrtf.html"
+SRC_URI="http://www.gnu.org/software/unrtf/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~s390"
+IUSE=""
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PN}-0.19.3-final.patch
+ # in 0.19.3 it's a tar file of 0.19.2
+ rm ${S}/AUTHORS
+}
+
+src_compile() {
+ make clean
+ emake || die
+}
+
+src_install() {
+ dobin unrtf bcount
+ doman unrtf.1
+ dohtml doc/unrtf.html
+ dodoc CHANGES COPYING README TODO
+}