summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-08 23:01:40 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-08 23:01:40 +0000
commit81512dd6b12dc6f43c09c7cdb92f2c398fd8c2ca (patch)
treece1e8d5cd3f24ff3f7abcc462541cd14ac8492a7 /app-text/xmlto/xmlto-0.0.17.ebuild
parentChange XVendorString to be compatible with upstream so people can strstr for ... (diff)
downloadhistorical-81512dd6b12dc6f43c09c7cdb92f2c398fd8c2ca.tar.gz
historical-81512dd6b12dc6f43c09c7cdb92f2c398fd8c2ca.tar.bz2
historical-81512dd6b12dc6f43c09c7cdb92f2c398fd8c2ca.zip
add inherit eutils
Diffstat (limited to 'app-text/xmlto/xmlto-0.0.17.ebuild')
-rw-r--r--app-text/xmlto/xmlto-0.0.17.ebuild25
1 files changed, 9 insertions, 16 deletions
diff --git a/app-text/xmlto/xmlto-0.0.17.ebuild b/app-text/xmlto/xmlto-0.0.17.ebuild
index 6a32673beec8..f14285f20bb4 100644
--- a/app-text/xmlto/xmlto-0.0.17.ebuild
+++ b/app-text/xmlto/xmlto-0.0.17.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.17.ebuild,v 1.5 2004/03/16 04:47:56 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.17.ebuild,v 1.6 2004/04/08 23:01:23 vapier Exp $
+
+inherit eutils
DESCRIPTION="A bash script for converting XML and DocBook formatted documents to a variety of output formats"
HOMEPAGE="http://cyberelk.net/tim/xmlto/"
SRC_URI="http://cyberelk.net/tim/data/${PN}/stable/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="~x86 ppc ~sparc ~alpha ~ia64 amd64 ~mips"
+IUSE=""
DEPEND="app-shells/bash
dev-libs/libxslt
@@ -18,29 +20,20 @@ DEPEND="app-shells/bash
# tetex? ( >=app-text/passivetex-1.4 )"
# Passivetex/xmltex need some sorting out <obz@gentoo.org>
-# not parrallel safe, thanks <agriffis@gentoo.org>, bug #33151
-MAKEOPTS="${MAKEOPTS} -j1"
-
src_unpack() {
-
- unpack ${A}; cd ${S}
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/${PN}-head-fix.patch
-
}
src_compile() {
-
econf || die
- emake || die
-
+ emake -j1 || die
}
src_install() {
-
make DESTDIR=${D} prefix="/usr" install || die
- dodoc AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README
+ dodoc AUTHORS ChangeLog FAQ INSTALL NEWS README
insinto /usr/share/doc/${P}/xml
doins doc/*.xml
-
}
-