summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-03 00:00:02 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-03 00:00:02 +0000
commit0114597073bcf812e29353e3d91c1ccc7ca82693 (patch)
treec5c0320cb52c75d3c03ea642e5fede45982dcf55 /app-text
parentportage patches (diff)
downloadhistorical-0114597073bcf812e29353e3d91c1ccc7ca82693.tar.gz
historical-0114597073bcf812e29353e3d91c1ccc7ca82693.tar.bz2
historical-0114597073bcf812e29353e3d91c1ccc7ca82693.zip
new package
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gnome-spell/ChangeLog10
-rw-r--r--app-text/gnome-spell/files/digest-gnome-spell-0.4.11
-rw-r--r--app-text/gnome-spell/gnome-spell-0.4.1.ebuild43
3 files changed, 54 insertions, 0 deletions
diff --git a/app-text/gnome-spell/ChangeLog b/app-text/gnome-spell/ChangeLog
new file mode 100644
index 000000000000..903943425f25
--- /dev/null
+++ b/app-text/gnome-spell/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/gnome-spell
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-spell/ChangeLog,v 1.1 2002/04/03 00:00:02 azarah Exp $
+
+*gnome-spell-0.4.1 (3 Apr 2002)
+
+ 3 Apr 2002; M.Schlemmer <azarah@gentoo.org> :
+
+ New gnome-spell package. Libtoolize.
+
diff --git a/app-text/gnome-spell/files/digest-gnome-spell-0.4.1 b/app-text/gnome-spell/files/digest-gnome-spell-0.4.1
new file mode 100644
index 000000000000..dc18f89ed135
--- /dev/null
+++ b/app-text/gnome-spell/files/digest-gnome-spell-0.4.1
@@ -0,0 +1 @@
+MD5 3771305d194314709430f0fd5f5d1ac8 gnome-spell-0.4.1.tar.gz 185220
diff --git a/app-text/gnome-spell/gnome-spell-0.4.1.ebuild b/app-text/gnome-spell/gnome-spell-0.4.1.ebuild
new file mode 100644
index 000000000000..9816529685fd
--- /dev/null
+++ b/app-text/gnome-spell/gnome-spell-0.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Jesse <jesse@dowellcompany.com>
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-spell/gnome-spell-0.4.1.ebuild,v 1.1 2002/04/03 00:00:02 azarah Exp $
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Gnome spellchecking component."
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/gnome-spell/${MY_P}.tar.gz"
+HOMEPAGE="http://www.gnome.org"
+
+DEPEND="virtual/glibc
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=gnome-base/gnome-core-1.4.0.4-r1
+ >=app-text/pspell-ispell-0.12-r1
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ local myconf=""
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+