summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-21 20:34:57 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-21 20:34:57 +0000
commit33c33cdbc0c21c28a50d1f6921f75730cd765d1d (patch)
tree9d30dad39d3a194edcf60ec15488b5b89b957ad8 /app-text
parentslotmove net-im/choqok from 0 to 4 (diff)
downloadhistorical-33c33cdbc0c21c28a50d1f6921f75730cd765d1d.tar.gz
historical-33c33cdbc0c21c28a50d1f6921f75730cd765d1d.tar.bz2
historical-33c33cdbc0c21c28a50d1f6921f75730cd765d1d.zip
Initial import. Ebuild by me and Constantin Bergemann, bug #219138. Required for pidgintex but is useful on its own ;)
Package-Manager: portage-2.1.7.15/cvs/Linux x86_64
Diffstat (limited to 'app-text')
-rw-r--r--app-text/mathtex/ChangeLog11
-rw-r--r--app-text/mathtex/Manifest4
-rw-r--r--app-text/mathtex/mathtex-1.03.ebuild44
-rw-r--r--app-text/mathtex/metadata.xml16
4 files changed, 75 insertions, 0 deletions
diff --git a/app-text/mathtex/ChangeLog b/app-text/mathtex/ChangeLog
new file mode 100644
index 000000000000..23d35bf55bf8
--- /dev/null
+++ b/app-text/mathtex/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/mathtex
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mathtex/ChangeLog,v 1.1 2009/12/21 20:34:57 pva Exp $
+
+*mathtex-1.03 (21 Dec 2009)
+
+ 21 Dec 2009; Peter Volkov <pva@gentoo.org> +mathtex-1.03.ebuild,
+ +metadata.xml:
+ Initial import. Ebuild by me and Constantin Bergemann, bug #219138.
+ Required for pidgintex but is useful on its own ;)
+
diff --git a/app-text/mathtex/Manifest b/app-text/mathtex/Manifest
new file mode 100644
index 000000000000..6df13ab01d2a
--- /dev/null
+++ b/app-text/mathtex/Manifest
@@ -0,0 +1,4 @@
+DIST mathtex-1.03.zip 143852 RMD160 e2aaf4d09fceea9d2a7e77c43738104c1f3b160d SHA1 a572d03a47183fbcbf24cfb45b7719769a77e219 SHA256 e30c19faf9682694a9ef299359c17cf7e5f5fb3bf247799a2f494d6ac0c572a1
+EBUILD mathtex-1.03.ebuild 985 RMD160 d9255a4876940e92f9f6372d2daeb0833e281134 SHA1 23f98f6c69c10b8356940009bb92d2d05978a5b4 SHA256 13ac569f1edb4278aa2a6ec0203ba221c6cd9bde0aed34ce368e23b5e8a8102d
+MISC ChangeLog 439 RMD160 58f37c5d0855fd045d4931e70c233d00cba73fbe SHA1 fb3e12bc2c00be8832756e3945c48b8322d3c81c SHA256 84bdb02967c09d5807742fe7971bd9d24202a69f9642b0a34b63cb777a9e3640
+MISC metadata.xml 623 RMD160 aacf780faa294748f249e37260931289c9673559 SHA1 345566cfda2e4b8f80519f75e1398f52f676dc39 SHA256 5de81bd142e6c96f5e5d86b04fb8df2f0a4c6b17f668199c3c037d274f06258d
diff --git a/app-text/mathtex/mathtex-1.03.ebuild b/app-text/mathtex/mathtex-1.03.ebuild
new file mode 100644
index 000000000000..c1698b33069a
--- /dev/null
+++ b/app-text/mathtex/mathtex-1.03.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mathtex/mathtex-1.03.ebuild,v 1.1 2009/12/21 20:34:57 pva Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="MathTeX lets you easily embed LaTeX math in your own html pages, blogs, wikis, etc"
+HOMEPAGE="http://www.forkosh.com/mathtex.html"
+SRC_URI="http://www.forkosh.com/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/dvipng
+ virtual/latex-base"
+DEPEND=""
+
+einfo_run_command() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_compile() {
+ einfo_run_command $(tc-getCC) \
+ ${CFLAGS} ${LDFLAGS} \
+ -DLATEX=\"/usr/bin/latex\" \
+ -DDVIPNG=\"/usr/bin/dvipng\" \
+ mathtex.c -o mathtex
+}
+
+src_install() {
+ dobin mathtex || die
+ dodoc README || die
+ dohtml mathtex.html || die
+}
+
+pkg_postinst() {
+ elog "To use mathtex in your web-pages, just link /usr/bin/mathtex"
+ elog "to your cgi-bin subdirectory!"
+}
diff --git a/app-text/mathtex/metadata.xml b/app-text/mathtex/metadata.xml
new file mode 100644
index 000000000000..ab1c52d05973
--- /dev/null
+++ b/app-text/mathtex/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+</maintainer>
+<longdescription>
+ MathTeX parses a LaTeX math expression and immediately emits the corresponding
+ gif (or png) image. It can be used as cgi program to embed LaTeX math in your
+ own html pages, blogs, wikis, etc. Just place an html img tag in your
+ document wherever you want to see the corresponding LaTeX expression. Take a
+ look at homepage for examples.
+</longdescription>
+</pkgmetadata>