summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-03-25 18:49:14 +0000
committerSimon Stelling <blubb@gentoo.org>2005-03-25 18:49:14 +0000
commit779ac11b3fd7ac942e9f922dfb15c74b2b23f557 (patch)
treef2b058fec650147d4cd93ab9951dff87de10c089 /app-text
parentVersion bump and fix for bug #84508. (diff)
downloadhistorical-779ac11b3fd7ac942e9f922dfb15c74b2b23f557.tar.gz
historical-779ac11b3fd7ac942e9f922dfb15c74b2b23f557.tar.bz2
historical-779ac11b3fd7ac942e9f922dfb15c74b2b23f557.zip
#86444
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gnomesword/ChangeLog6
-rw-r--r--app-text/gnomesword/Manifest5
-rw-r--r--app-text/gnomesword/files/gnomesword-2.1.1-gcc-3.4.patch13
-rw-r--r--app-text/gnomesword/gnomesword-2.1.1.ebuild12
4 files changed, 30 insertions, 6 deletions
diff --git a/app-text/gnomesword/ChangeLog b/app-text/gnomesword/ChangeLog
index 37853055f5f3..32811d11f9ba 100644
--- a/app-text/gnomesword/ChangeLog
+++ b/app-text/gnomesword/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/gnomesword
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/ChangeLog,v 1.4 2005/01/01 16:16:46 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/ChangeLog,v 1.5 2005/03/25 18:49:14 blubb Exp $
+
+ 25 Mar 2005; <blubb@gentoo.org> +files/gnomesword-2.1.1-gcc-3.4.patch,
+ gnomesword-2.1.1.ebuild:
+ added Will Brigg's patch and ~amd64 keyword, see bug #86444
18 Sep 2004; Jon Hood <squinky86@gentoo.org> gnomesword-2.1.1.ebuild:
Stable on x86.
diff --git a/app-text/gnomesword/Manifest b/app-text/gnomesword/Manifest
index 29e5d09b3d3f..7f1361fd09f1 100644
--- a/app-text/gnomesword/Manifest
+++ b/app-text/gnomesword/Manifest
@@ -1,4 +1,5 @@
-MD5 9694b86211d32096872f3439c333fd8d ChangeLog 659
-MD5 6abf8467617f157a7fb7e302b1658c2c gnomesword-2.1.1.ebuild 911
+MD5 1f69244d65eb806fad7be1c91c79220d ChangeLog 817
+MD5 3ff99c5b8ba93bd19f4828fb768f3a79 gnomesword-2.1.1.ebuild 1011
MD5 e42392e84823e6329bc4b8228fd7b9bd metadata.xml 222
MD5 c0c12f952a54eadc42e02d1a65435ed5 files/digest-gnomesword-2.1.1 69
+MD5 c7c3a66ca0618cbc1ec047753829a4aa files/gnomesword-2.1.1-gcc-3.4.patch 365
diff --git a/app-text/gnomesword/files/gnomesword-2.1.1-gcc-3.4.patch b/app-text/gnomesword/files/gnomesword-2.1.1-gcc-3.4.patch
new file mode 100644
index 000000000000..4152dc22e8c0
--- /dev/null
+++ b/app-text/gnomesword/files/gnomesword-2.1.1-gcc-3.4.patch
@@ -0,0 +1,13 @@
+--- src/backend/sword_main.cc 2004-07-01 17:45:30.000000000 +0200
++++ src/backend/sword_main.cc.new 2005-03-25 20:42:53.566287072 +0100
+@@ -190,8 +190,8 @@
+ VerseKey key;
+ GList *retlist = NULL;
+ char *book = NULL;
+- unsigned int bytes_read;
+- unsigned int bytes_written;
++ gsize bytes_read;
++ gsize bytes_written;
+ GError *error;
+ int i = 0, j = 0, x = 2;
+
diff --git a/app-text/gnomesword/gnomesword-2.1.1.ebuild b/app-text/gnomesword/gnomesword-2.1.1.ebuild
index 6e67553594bc..389814c3b181 100644
--- a/app-text/gnomesword/gnomesword-2.1.1.ebuild
+++ b/app-text/gnomesword/gnomesword-2.1.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/gnomesword-2.1.1.ebuild,v 1.7 2005/01/01 16:16:46 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/gnomesword-2.1.1.ebuild,v 1.8 2005/03/25 18:49:14 blubb Exp $
-inherit libtool gnome2
+inherit libtool gnome2 eutils
DESCRIPTION="Gnome Bible study software"
HOMEPAGE="http://gnomesword.sf.net/"
@@ -11,7 +11,7 @@ RESTRICT="nomirror"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="x86 ~ppc ~amd64"
IUSE="spell"
RDEPEND="=gnome-extra/libgtkhtml-3.0*
@@ -31,3 +31,9 @@ DEPEND="${RDEPEND}
G2CONF="${G2CONF} --enable-sword_cvs $(use_enable spell pspell)"
DOCS="COPYING NEWS ChangeLog README TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gnomesword-2.1.1-gcc-3.4.patch
+}