summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-01-10 17:19:22 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-01-10 17:19:22 +0000
commit9141a294b94aec0977a2ec0176e5fa84d3ae1cc6 (patch)
treec4e9080b4513347092998d66366f73c8986aae4c /app-text
parentRemove mask for app-emacs/navi2ch. (diff)
downloadhistorical-9141a294b94aec0977a2ec0176e5fa84d3ae1cc6.tar.gz
historical-9141a294b94aec0977a2ec0176e5fa84d3ae1cc6.tar.bz2
historical-9141a294b94aec0977a2ec0176e5fa84d3ae1cc6.zip
Version bumped. Added native/libhanspell-*.so.
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64
Diffstat (limited to 'app-text')
-rw-r--r--app-text/omegat/ChangeLog9
-rw-r--r--app-text/omegat/omegat-1.8.1_p01.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/app-text/omegat/ChangeLog b/app-text/omegat/ChangeLog
index 246a921cae49..6b336c2abf5e 100644
--- a/app-text/omegat/ChangeLog
+++ b/app-text/omegat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/omegat
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/omegat/ChangeLog,v 1.7 2008/11/04 16:17:21 matsuu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/omegat/ChangeLog,v 1.8 2009/01/10 17:19:22 matsuu Exp $
+
+*omegat-1.8.1_p01 (10 Jan 2009)
+
+ 10 Jan 2009; MATSUU Takuto <matsuu@gentoo.org> +omegat-1.8.1_p01.ebuild:
+ Version bumped. Added native/libhanspell-*.so.
*omegat-1.8.1 (04 Nov 2008)
diff --git a/app-text/omegat/omegat-1.8.1_p01.ebuild b/app-text/omegat/omegat-1.8.1_p01.ebuild
new file mode 100644
index 000000000000..d35ef1e12383
--- /dev/null
+++ b/app-text/omegat/omegat-1.8.1_p01.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/omegat/omegat-1.8.1_p01.ebuild,v 1.1 2009/01/10 17:19:22 matsuu Exp $
+
+JAVA_PKG_BSFIX_NAME="build.xml build-impl.xml profiler-build-impl.xml"
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P="OmegaT_${PV/_p/_}"
+DESCRIPTION="Open source computer assisted translation (CAT) tool written in Java."
+HOMEPAGE="http://www.omegat.org/"
+SRC_URI="mirror://sourceforge/omegat/${MY_P}_Source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}"
+
+src_install() {
+ local myarch
+ if use x86 ; then
+ myarch=i386
+ elif use amd64 ; then
+ myarch=amd64
+ fi
+
+ java-pkg_dojar dist/*.jar
+ dosym /usr/share/doc/${PF}/html "${JAVA_PKG_JARDEST}"/docs
+
+ if [ -n "${myarch}" ] ; then
+ libopts -m0755
+ java-pkg_sointo "${JAVA_PKG_JARDEST}"/native
+ java-pkg_doso dist/native/libhunspell-${myarch}.so
+ fi
+
+ java-pkg_jarinto "${JAVA_PKG_JARDEST}"/lib
+ java-pkg_dojar dist/lib/*.jar
+
+ java-pkg_dolauncher ${PN} --jar OmegaT.jar
+
+ dodoc release/changes.txt release/readme*.txt
+ dohtml -A properties -r docs/*
+ docinto lib; dodoc lib/*.txt
+
+ doicon images/OmegaT.png
+ make_desktop_entry ${PN} "OmegaT" "OmegaT" "Application;Office"
+}