summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-12 23:18:18 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-12 23:18:18 +0000
commitf89d71901135734030660542e9f5aced10c9ee0e (patch)
tree56358ded1788a8e84aab62fa06a7f2ada9e1f131 /app-text
parentAdded USE dependent nls compilation (diff)
downloadhistorical-f89d71901135734030660542e9f5aced10c9ee0e.tar.gz
historical-f89d71901135734030660542e9f5aced10c9ee0e.tar.bz2
historical-f89d71901135734030660542e9f5aced10c9ee0e.zip
Added USE dependent nls compilation
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enscript/ChangeLog8
-rw-r--r--app-text/enscript/enscript-1.6.3-r1.ebuild53
-rw-r--r--app-text/enscript/files/digest-enscript-1.6.3-r11
3 files changed, 61 insertions, 1 deletions
diff --git a/app-text/enscript/ChangeLog b/app-text/enscript/ChangeLog
index 7b948552c008..b1db06a2253d 100644
--- a/app-text/enscript/ChangeLog
+++ b/app-text/enscript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/enscript
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/ChangeLog,v 1.4 2002/02/04 20:29:38 m0rpheus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/ChangeLog,v 1.5 2002/03/12 23:18:18 seemant Exp $
+
+*enscript-1.6.3 (12 Mar 2002)
+
+ 12 Mar 2002; Seemant Kulleen <seemant@gentoo.org> :
+
+ Added USE dependent nls compilation (submitted by Matthew Kennedy).
*enscript-1.6.3 (4 Feb 2002)
diff --git a/app-text/enscript/enscript-1.6.3-r1.ebuild b/app-text/enscript/enscript-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..946804511425
--- /dev/null
+++ b/app-text/enscript/enscript-1.6.3-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/enscript-1.6.3-r1.ebuild,v 1.1 2002/03/12 23:18:18 seemant Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="http://www.iki.fi/mtr/genscript/${P}.tar.gz"
+
+HOMEPAGE="http:/www.gnu.org/software/enscript/enscript.html"
+DESCRIPTION="GNU's enscript is a powerful text-to-postsript converter"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myopts
+
+ if [ -z "`use nls`" ]
+ then
+ myopts="--disable-nls"
+ else
+ myopts="--enable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myopts}
+ assert
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog FAQ.html NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ echo "
+ Now, customize /etc/enscript.cfg.
+ "
+}
diff --git a/app-text/enscript/files/digest-enscript-1.6.3-r1 b/app-text/enscript/files/digest-enscript-1.6.3-r1
new file mode 100644
index 000000000000..57b3e69cc3f8
--- /dev/null
+++ b/app-text/enscript/files/digest-enscript-1.6.3-r1
@@ -0,0 +1 @@
+MD5 ec717f8b0de7db00a21a21f70d354610 enscript-1.6.3.tar.gz 814308