summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-07-13 23:54:01 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-07-13 23:54:01 +0000
commit59f362ca55eb961534e0a2246cb5995c5d58428a (patch)
tree9a73fa80f9f36d4be5d04dae1ec590c28312b1bd /dev-ada
parentnew package - a tool to help creating C bindings for ada (diff)
downloadhistorical-59f362ca55eb961534e0a2246cb5995c5d58428a.tar.gz
historical-59f362ca55eb961534e0a2246cb5995c5d58428a.tar.bz2
historical-59f362ca55eb961534e0a2246cb5995c5d58428a.zip
new package - a tool to help creating C bindings for ada
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/cbind/Manifest3
-rw-r--r--dev-ada/cbind/cbind-6.ebuild32
-rw-r--r--dev-ada/cbind/files/cbind6.diff191
-rw-r--r--dev-ada/cbind/files/digest-cbind-61
4 files changed, 226 insertions, 1 deletions
diff --git a/dev-ada/cbind/Manifest b/dev-ada/cbind/Manifest
index 29808a975772..c14915effb38 100644
--- a/dev-ada/cbind/Manifest
+++ b/dev-ada/cbind/Manifest
@@ -1,3 +1,4 @@
-MD5 a4d354d418e9d25a01d021cb6dc1f8a9 cbind-6.ebuild 655
+MD5 b846c936f3641f258a1ad057acae6951 cbind-6.ebuild 752
+MD5 c3031578a2e86fc61e0523838fef8ba0 ChangeLog 484
MD5 54d17954817798fdfed5399cee7f0373 files/digest-cbind-6 55
MD5 aa4cf2876e3e245ad93133ff4deb78c5 files/cbind6.diff 5268
diff --git a/dev-ada/cbind/cbind-6.ebuild b/dev-ada/cbind/cbind-6.ebuild
new file mode 100644
index 000000000000..a7d24c734648
--- /dev/null
+++ b/dev-ada/cbind/cbind-6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/cbind/cbind-6.ebuild,v 1.1 2003/07/13 23:53:59 george Exp $
+
+S="${WORKDIR}/${PN}${PV}"
+DESCRIPTION="This tool is designed to aid in the creation of Ada bindings to C."
+SRC_URI="http://unicoi.kennesaw.edu/ase/ase02_02/tools/${PN}/${PN}${PV}.zip"
+HOMEPAGE="http://www.rational.com/"
+LICENSE="GMGPL"
+
+DEPEND="dev-lang/gnat"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_unpack() {
+ unpack "${PN}${PV}.zip"
+ cd "${S}"
+ patch -p1 < "${FILESDIR}/${PN}${PV}.diff"
+}
+
+src_compile() {
+ make || die
+}
+
+src_install () {
+ make PREFIX=${D}/usr/ install || die
+
+ # Install documentation.
+ dodoc README
+}
diff --git a/dev-ada/cbind/files/cbind6.diff b/dev-ada/cbind/files/cbind6.diff
new file mode 100644
index 000000000000..0655765ece75
--- /dev/null
+++ b/dev-ada/cbind/files/cbind6.diff
@@ -0,0 +1,191 @@
+diff -Naur cbind6.orig/allocate.c cbind6/allocate.c
+--- cbind6.orig/allocate.c 1995-05-19 16:53:10.000000000 +0200
++++ cbind6/allocate.c 2003-06-09 21:48:02.000000000 +0200
+@@ -4,7 +4,7 @@
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include "ansi.h"
+ #include "config.h"
+ #include "allocate.h"
+diff -Naur cbind6.orig/buffer.c cbind6/buffer.c
+--- cbind6.orig/buffer.c 1995-05-19 16:53:44.000000000 +0200
++++ cbind6/buffer.c 2003-06-09 21:48:02.000000000 +0200
+@@ -5,7 +5,7 @@
+ */
+
+ #include <sys/types.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include "ansi.h"
+ #include "buffer.h"
+ #include "allocate.h"
+diff -Naur cbind6.orig/cbind.c cbind6/cbind.c
+--- cbind6.orig/cbind.c 1995-05-19 17:17:06.000000000 +0200
++++ cbind6/cbind.c 2003-06-09 21:48:02.000000000 +0200
+@@ -6,7 +6,7 @@
+ #include <sys/types.h>
+ #include <string.h>
+ #include <unistd.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+ #undef NULL
+ #define NULL 0
+diff -Naur cbind6.orig/cdep.c cbind6/cdep.c
+--- cbind6.orig/cdep.c 1995-05-19 19:19:36.000000000 +0200
++++ cbind6/cdep.c 2003-06-09 21:48:02.000000000 +0200
+@@ -12,6 +12,7 @@
+ #include "cpp.h"
+ #include "cpp_hide.h"
+ #include "allocate.h"
++#include "host.h"
+
+ #undef NULL
+ #define NULL 0
+diff -Naur cbind6.orig/errors.c cbind6/errors.c
+--- cbind6.orig/errors.c 1994-10-28 19:44:44.000000000 +0100
++++ cbind6/errors.c 2003-06-09 21:48:02.000000000 +0200
+@@ -118,9 +118,6 @@
+ static void
+ unix_error()
+ {
+- extern char *sys_errlist[];
+- extern int sys_nerr;
+-
+ if (errno != 0) {
+ if (errno > 0 && errno < sys_nerr) {
+ fputs(sys_errlist[errno], stderr);
+diff -Naur cbind6.orig/files.c cbind6/files.c
+--- cbind6.orig/files.c 1995-05-19 16:45:30.000000000 +0200
++++ cbind6/files.c 2003-06-09 21:48:02.000000000 +0200
+@@ -1,5 +1,6 @@
+ #include "ansi.h"
+ #include "hostinfo.h"
++#include "host.h"
+ #include "config.h"
+
+ #include <sys/types.h>
+@@ -11,7 +12,7 @@
+ #include <sys/mman.h>
+ #else
+ #include <unistd.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #endif
+
+ #undef NULL
+diff -Naur cbind6.orig/hostinfo cbind6/hostinfo
+--- cbind6.orig/hostinfo 1994-04-07 15:03:16.000000000 +0200
++++ cbind6/hostinfo 2003-06-09 21:48:02.000000000 +0200
+@@ -4,25 +4,10 @@
+
+ echo '/* This file is automatically generated */' > $1
+ echo '#define _H_HOSTINFO_' >> $1
+-htype >> $1
+-
+-cat > llchk.c << _STOP
+-main()
+-{
+- struct s {
+- char c;
+- long long x;
+- };
+- printf("\n#define SIZEOF_LONG_LONG\t\t%d\n", sizeof(long long));
+- printf("#define ALIGNOF_LONG_LONG\t\t%d\n\n",
+- sizeof(char) + ((sizeof(struct s) - (sizeof(char)+sizeof(long long)))));
+-}
+-_STOP
++./htype >> $1
+
+ cc llchk.c >& /dev/null
+ if ($status == 0) a.out >> $1
+-rm -f a.out
+-rm -f llchk.c
+
+ echo '#define HOST_OS '`uname` >> $1
+
+diff -Naur cbind6.orig/htype.c cbind6/htype.c
+--- cbind6.orig/htype.c 1995-05-19 16:52:08.000000000 +0200
++++ cbind6/htype.c 2003-06-09 21:48:02.000000000 +0200
+@@ -132,10 +132,14 @@
+ printf("\n#define CHARS_ARE_%sSIGNED\n", (((char)-1) < 0) ? "" : "UN");
+
+ if (*p == 1) {
++ puts("#ifndef BIG_ENDIAN");
+ puts("#define BIG_ENDIAN");
++ puts("#endif");
+ }
+ else {
++ puts("#ifndef LITTLE_ENDIAN");
+ puts("#define LITTLE_ENDIAN");
++ puts("#endif");
+ }
+
+ return 0;
+diff -Naur cbind6.orig/llchk.c cbind6/llchk.c
+--- cbind6.orig/llchk.c 1970-01-01 01:00:00.000000000 +0100
++++ cbind6/llchk.c 2003-06-09 21:48:02.000000000 +0200
+@@ -0,0 +1,13 @@
++
++main()
++{
++ struct s {
++ char c;
++ long long x;
++ };
++ printf("\n#define SIZEOF_LONG_LONG\t\t%d\n", sizeof(long long));
++ printf("#define ALIGNOF_LONG_LONG\t\t%d\n\n",
++ sizeof(char) + ((sizeof(struct s) - (sizeof(char)+sizeof(long long)))));
++}
++
++
+diff -Naur cbind6.orig/Makefile cbind6/Makefile
+--- cbind6.orig/Makefile 1995-09-22 12:21:32.000000000 +0200
++++ cbind6/Makefile 2003-06-09 21:49:16.000000000 +0200
+@@ -91,8 +91,11 @@
+
+ install: all
+ - strip cbpp cbfe cbind cdep
+- - rm -f $(HOME)/bin/cbpp $(HOME)/bin/cbfe $(HOME)/bin/cbind $(HOME)/bin/cdep
+- - cp cbpp cbfe cbind cdep $(HOME)/bin
++ - rm -f $(PREFIX)/bin/cbpp $(PREFIX)/bin/cbfe $(PREFIX)/bin/cbind $(PREFIX)/bin/cdep
++ - install -D cbpp $(PREFIX)/bin/cbpp
++ - install -D cbfe $(PREFIX)/bin/cbfe
++ - install -D cbind $(PREFIX)/bin/cbind
++ - install -D cdep $(PREFIX)/bin/cdep
+
+
+
+@@ -132,14 +135,14 @@
+ mkmf -f $(MAKEFILE)
+
+ backup:
+- - rm -f $(HOME)/save/newc2a.tar.Z
+- tar -chf $(HOME)/save/newc2a.tar *.1 *.c *.h *.y *.prf $(SCRIPTS) DOCS README makefile
+- compress $(HOME)/save/newc2a.tar
++ - rm -f $(PREFIX)/save/newc2a.tar.Z
++ tar -chf $(PREFIX)/save/newc2a.tar *.1 *.c *.h *.y *.prf $(SCRIPTS) DOCS README makefile
++ compress $(PREFIX)/save/newc2a.tar
+
+ touch:; touch $(GENED_SRC)
+
+ hostinfo.h: htype hostinfo
+- hostinfo $@
++ ./hostinfo $@
+
+ c_perf.c: c.prf
+ gperf -N c_rsvd -t -p c.prf > $@
+diff -Naur cbind6.orig/units.c cbind6/units.c
+--- cbind6.orig/units.c 1995-09-22 12:06:46.000000000 +0200
++++ cbind6/units.c 2003-06-09 21:48:02.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <stdio.h>
++#include "host.h"
+ #include "ansi.h"
+ #include "files.h"
+ #include "units.h"
diff --git a/dev-ada/cbind/files/digest-cbind-6 b/dev-ada/cbind/files/digest-cbind-6
new file mode 100644
index 000000000000..b6e2ca7b86c4
--- /dev/null
+++ b/dev-ada/cbind/files/digest-cbind-6
@@ -0,0 +1 @@
+MD5 250a2db4799376d3586070c175d6c279 cbind6.zip 101939