summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-02-07 19:44:01 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-02-07 19:44:01 +0000
commit9ebb8079cd7753d71d9d086aec5e7069c4f2d10a (patch)
treef70e801cd12d211a91e090b5b640481ae266a04b /dev-db/mysql-proxy/mysql-proxy-0.6.1.ebuild
parentfix a typo pointed out by Holger Hoffstätte <holger AT wizards DOT de> in bu... (diff)
downloadhistorical-9ebb8079cd7753d71d9d086aec5e7069c4f2d10a.tar.gz
historical-9ebb8079cd7753d71d9d086aec5e7069c4f2d10a.tar.bz2
historical-9ebb8079cd7753d71d9d086aec5e7069c4f2d10a.zip
version bump
Package-Manager: portage-2.1.4
Diffstat (limited to 'dev-db/mysql-proxy/mysql-proxy-0.6.1.ebuild')
-rw-r--r--dev-db/mysql-proxy/mysql-proxy-0.6.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-db/mysql-proxy/mysql-proxy-0.6.1.ebuild b/dev-db/mysql-proxy/mysql-proxy-0.6.1.ebuild
new file mode 100644
index 000000000000..bdf767a0f72d
--- /dev/null
+++ b/dev-db/mysql-proxy/mysql-proxy-0.6.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-proxy/mysql-proxy-0.6.1.ebuild,v 1.1 2008/02/07 19:44:00 wschlich Exp $
+
+inherit eutils
+
+DESCRIPTION="A Proxy for the MySQL Client/Server protocol"
+HOMEPAGE="http://forge.mysql.com/wiki/MySQL_Proxy"
+SRC_URI="mirror://mysql/Downloads/MySQL-Proxy/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua examples"
+DEPEND=">=dev-libs/libevent-1.0
+ >=dev-libs/glib-2.0
+ >=virtual/mysql-4.0
+ lua? ( >=dev-lang/lua-5.1 )"
+
+src_compile() {
+ econf \
+ --with-mysql \
+ $(use_with lua) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dosbin src/mysql-proxy
+ if useq lua; then
+ insinto /usr/share/${PN}
+ doins lib/*.lua
+ insinto /usr/share/${PN}/proxy
+ doins lib/proxy/*.lua
+ if useq examples; then
+ insinto /usr/share/${PN}/examples
+ doins examples/*.lua
+ fi
+ fi
+ dodoc README INSTALL NEWS
+ newinitd "${FILESDIR}/${PV}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PV}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You might want to have a look at"
+ einfo "http://dev.mysql.com/tech-resources/articles/proxy-gettingstarted.html"
+ einfo "on how to get started with MySQL Proxy."
+ einfo
+}