summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 19:39:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 19:39:14 +0000
commit7c12c8b7b797ecb9f332eacb7e2780a64013609b (patch)
tree45999d1b1fb227fc3add9f5d84581670464b0f44 /dev-db/sqlite
parentAdd atomicparsley dep for AAC tagging; bug 326171 (diff)
downloadhistorical-7c12c8b7b797ecb9f332eacb7e2780a64013609b.tar.gz
historical-7c12c8b7b797ecb9f332eacb7e2780a64013609b.tar.bz2
historical-7c12c8b7b797ecb9f332eacb7e2780a64013609b.zip
Delete older ebuilds.
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/files/sqlite-3.6.20-fts3.patch65
-rw-r--r--dev-db/sqlite/sqlite-3.6.20-r1.ebuild118
-rw-r--r--dev-db/sqlite/sqlite-3.6.21.ebuild114
-rw-r--r--dev-db/sqlite/sqlite-3.6.23.ebuild148
4 files changed, 0 insertions, 445 deletions
diff --git a/dev-db/sqlite/files/sqlite-3.6.20-fts3.patch b/dev-db/sqlite/files/sqlite-3.6.20-fts3.patch
deleted file mode 100644
index 3c7cb811b56c..000000000000
--- a/dev-db/sqlite/files/sqlite-3.6.20-fts3.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff -urN sqlite-3.6.20-orig/Makefile.in sqlite-3.6.20/Makefile.in
---- sqlite-3.6.20-orig/Makefile.in 2009-11-13 20:10:50.617845091 -0600
-+++ sqlite-3.6.20/Makefile.in 2009-11-13 20:10:54.994843274 -0600
-@@ -150,6 +150,11 @@
- LIBTOOL = ./libtool
- ALLOWRELEASE = @ALLOWRELEASE@
-
-+# FTS3
-+#
-+TCC += -DSQLITE_CORE
-+TCC += -DSQLITE_ENABLE_FTS3=1
-+
- # libtool compile/link/install
- LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(TCC) $(LTCOMPILE_EXTRAS)
- LTLINK = $(LIBTOOL) --mode=link $(TCC) $(LTCOMPILE_EXTRAS) @LDFLAGS@ $(LTLINK_EXTRAS)
-@@ -187,7 +192,11 @@
- USE_AMALGAMATION = @USE_AMALGAMATION@
- LIBOBJ = $(OBJS$(USE_AMALGAMATION))
-
--
-+# Object files for FTS
-+#
-+LIBOBJ += \
-+ fts3.lo fts3_expr.lo fts3_hash.lo fts3_porter.lo fts3_tokenizer.lo fts3_tokenizer1.lo
-+
- # All of the source code files.
- #
- SRC = \
-@@ -832,3 +841,24 @@
- sqlite3.dll: $(REAL_LIBOBJ) sqlite3.def
- $(TCC) -shared -o $@ sqlite3.def \
- -Wl,"--strip-all" $(REAL_LIBOBJ)
-+
-+#
-+# FTS3
-+#
-+fts3.lo: $(TOP)/ext/fts3/fts3.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3.c
-+
-+fts3_expr.lo: $(TOP)/ext/fts3/fts3_expr.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3_expr.c
-+
-+fts3_hash.lo: $(TOP)/ext/fts3/fts3_hash.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3_hash.c
-+
-+fts3_porter.lo: $(TOP)/ext/fts3/fts3_porter.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3_porter.c
-+
-+fts3_tokenizer.lo: $(TOP)/ext/fts3/fts3_tokenizer.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3_tokenizer.c
-+
-+fts3_tokenizer1.lo: $(TOP)/ext/fts3/fts3_tokenizer1.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3_tokenizer1.c
-diff -urN sqlite-3.6.20-orig/src/main.c sqlite-3.6.20/src/main.c
---- sqlite-3.6.20-orig/src/main.c 2009-11-13 20:10:50.674843345 -0600
-+++ sqlite-3.6.20/src/main.c 2009-11-13 20:11:30.403822462 -0600
-@@ -17,7 +17,7 @@
- #include "sqliteInt.h"
-
- #ifdef SQLITE_ENABLE_FTS3
--# include "fts3.h"
-+# include "../ext/fts3/fts3.h"
- #endif
- #ifdef SQLITE_ENABLE_RTREE
- # include "rtree.h"
diff --git a/dev-db/sqlite/sqlite-3.6.20-r1.ebuild b/dev-db/sqlite/sqlite-3.6.20-r1.ebuild
deleted file mode 100644
index 962bb13ee5a3..000000000000
--- a/dev-db/sqlite/sqlite-3.6.20-r1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.20-r1.ebuild,v 1.9 2010/01/02 18:27:30 armin76 Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib versionator
-
-DESCRIPTION="an SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-SRC_URI="http://www.sqlite.org/${P}.tar.gz
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )
- !tcl? ( mirror://gentoo/sqlite3.h-${PV}.bz2 )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc fts3 icu +readline soundex tcl +threadsafe"
-RESTRICT="!tcl? ( test )"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )"
-
-pkg_setup() {
- if ! use tcl; then
- ewarn "Installation of SQLite with \"tcl\" USE flag enabled provides more (TCL-unrelated) functionality."
-
- if use icu; then
- ewarn "Support for ICU is enabled only when \"tcl\" USE flag is enabled."
- fi
-
- ebeep 1
- fi
-}
-
-src_prepare() {
- if use icu; then
- rm -f test/like.test
- fi
-
- # http://bugs.gentoo.org/show_bug.cgi?id=293405
- # Needed to compile without tcl installed but fails to compile when it
- # it installed
- use fts3 && ! has_version dev-lang/tcl && epatch "${FILESDIR}/sqlite-3.6.20-fts3.patch"
-
- epunt_cxx
-}
-
-src_configure() {
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- # Avoid "./.libs/libsqlite3.so: undefined reference to `sqlite3RtreeInit'" during non-amalgamation building.
- if use tcl; then
- append-cppflags -DSQLITE_ENABLE_RTREE
- fi
-
- if use icu && use tcl; then
- append-cppflags -DSQLITE_ENABLE_ICU
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
-
- # Support soundex, bug #143794
- use soundex && append-cppflags -DSQLITE_SOUNDEX
-
- # http://bugs.gentoo.org/show_bug.cgi?id=207701
- use fts3 && append-cppflags -DSQLITE_ENABLE_FTS3=1
-
- econf \
- $(use_enable debug) \
- $(use_enable readline) \
- $(use_enable threadsafe) \
- $(use_enable threadsafe cross-thread-connections) \
- $(use_enable tcl)
-}
-
-src_compile() {
- use tcl || cp "${WORKDIR}/sqlite3.h-${PV}" sqlite3.h
- emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-
- if ! use tcl; then
- ewarn "You must enable the tcl USE flag if you want to run the testsuite."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.6.21.ebuild b/dev-db/sqlite/sqlite-3.6.21.ebuild
deleted file mode 100644
index 766c909ba036..000000000000
--- a/dev-db/sqlite/sqlite-3.6.21.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.21.ebuild,v 1.10 2010/03/14 16:47:43 armin76 Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib versionator
-
-DESCRIPTION="an SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-
-SRC_URI="
- tcl? ( http://www.sqlite.org/${P}.tar.gz )
- !tcl? (
- test? ( http://www.sqlite.org/${P}.tar.gz )
- !test? ( http://www.sqlite.org/${PN}-amalgamation-${PV}.tar.gz )
- )
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha ~amd64 arm ~hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc +fts3 icu +readline soundex tcl +threadsafe test"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/tcl )
- doc? ( app-arch/unzip )"
-
-src_prepare() {
- if use icu; then
- rm -f test/like.test
- fi
-
- epunt_cxx
-}
-
-src_configure() {
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if use tcl || use test; then
- # Normal tarball.
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- # Amalgamation tarball.
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Support soundex, bug #143794
- if use soundex; then
- append-cppflags -DSQLITE_SOUNDEX
- fi
-
- # Support FTS3, bug #207701
- if use fts3; then
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
- fi
-
- # The amalgamation source doesn't have these via Makefile
- if use debug; then
- append-cppflags -DSQLITE_DEBUG=1
- else
- append-cppflags -DNDEBUG
- fi
-
- # amalgamation doesn't have tcl
- econf \
- $(use_enable readline) \
- $(use_enable threadsafe) \
- $(use tcl && echo --enable-tcl) \
- $(use !tcl && use test && echo --disable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.6.23.ebuild b/dev-db/sqlite/sqlite-3.6.23.ebuild
deleted file mode 100644
index c6e316b0d872..000000000000
--- a/dev-db/sqlite/sqlite-3.6.23.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.23.ebuild,v 1.2 2010/03/19 18:33:37 grobian Exp $
-
-EAPI="3"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-
-SRC_URI="
- tcl? ( http://www.sqlite.org/${P}.tar.gz )
- !tcl? (
- test? ( http://www.sqlite.org/${P}.tar.gz )
- !test? ( http://www.sqlite.org/${PN}-amalgamation-${PV}.tar.gz )
- )
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc extensions +fts3 icu +readline secure-delete soundex tcl +threadsafe test"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/tcl )
- doc? ( app-arch/unzip )"
-
-src_prepare() {
- if use icu; then
- rm -f test/like.test
- fi
-
- if use tcl || use test; then
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes.patch"
- epatch "${FILESDIR}/${PN}-3.6.22-dlopen.patch" # bug 300836
- eautoreconf # dlopen.patch patches configure.ac
- else
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes-amalgamation.patch"
- fi
-
- eautoreconf # for MiNT and interix
- epunt_cxx
-}
-
-src_configure() {
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if use tcl || use test; then
- # Normal tarball.
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- # Amalgamation tarball.
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Support FTS3, bug #207701
- if use fts3; then
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
- fi
-
- # Enable secure_delete pragma by default
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Support soundex, bug #143794
- if use soundex; then
- append-cppflags -DSQLITE_SOUNDEX
- fi
-
- # The amalgamation source doesn't have these via Makefile
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
-
- local extensions_option
- if use tcl || use test; then
- extensions_option="load-extension"
- else
- extensions_option="dynamic-extensions"
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ ${CHOST} == *-darwin[56789] ]] ; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE=0
- fi
-
- # `configure` from amalgamation tarball doesn't support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $({ use tcl || use test; } && echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(use_enable threadsafe) \
- $(use tcl && echo --enable-tcl) \
- $(use !tcl && use test && echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}