summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2007-03-11 15:57:36 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2007-03-11 15:57:36 +0000
commit989a706048b3e2efc3b1ba838bbcd6c7bf0f1c8e (patch)
tree2bb9777b069ab77aedcfc12845a476048ce20420 /dev-haskell/fgl/fgl-5.2.ebuild
parentnew upstream release. (diff)
downloadhistorical-989a706048b3e2efc3b1ba838bbcd6c7bf0f1c8e.tar.gz
historical-989a706048b3e2efc3b1ba838bbcd6c7bf0f1c8e.tar.bz2
historical-989a706048b3e2efc3b1ba838bbcd6c7bf0f1c8e.zip
Added dummy library for virtual/ghc's fgl package
Package-Manager: portage-2.1.2-r5
Diffstat (limited to 'dev-haskell/fgl/fgl-5.2.ebuild')
-rw-r--r--dev-haskell/fgl/fgl-5.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-haskell/fgl/fgl-5.2.ebuild b/dev-haskell/fgl/fgl-5.2.ebuild
new file mode 100644
index 000000000000..131c9c18a0f2
--- /dev/null
+++ b/dev-haskell/fgl/fgl-5.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/fgl/fgl-5.2.ebuild,v 1.1 2007/03/11 15:57:36 kolmodin Exp $
+
+inherit ghc-package
+
+DESCRIPTION="A functional graph library for Haskell."
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI=""
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="=virtual/ghc-6.4*"
+
+pkg_setup () {
+ ghc-package_pkg_setup
+ einfo "This library is already provided by ghc. This ebuild does nothing."
+}
+
+src_install () {
+ dodir "$(ghc-libdir)"
+ touch "${D}/$(ghc-libdir)/.${P}.ghc-updater"
+}