summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-03-06 05:31:21 +0000
committerMark Wright <gienah@gentoo.org>2012-03-06 05:31:21 +0000
commit917f50fec0638ed6bc75ce90fdae8ba5afdbe34f (patch)
treedb45469f7a57f81eca30b14ba9930bdf2c96dc28 /dev-haskell/haddock/haddock-2.10.0.ebuild
parentVersion bump. (diff)
downloadhistorical-917f50fec0638ed6bc75ce90fdae8ba5afdbe34f.tar.gz
historical-917f50fec0638ed6bc75ce90fdae8ba5afdbe34f.tar.bz2
historical-917f50fec0638ed6bc75ce90fdae8ba5afdbe34f.zip
Bump to 2.10.0, which is the same version included in ghc 7.4.1. Remove haddock-2.10.0_pre20120202, since the haddock 2.10.0 included in ghc 7.4.1 is now on hackage.
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/haddock/haddock-2.10.0.ebuild')
-rw-r--r--dev-haskell/haddock/haddock-2.10.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-haskell/haddock/haddock-2.10.0.ebuild b/dev-haskell/haddock/haddock-2.10.0.ebuild
new file mode 100644
index 000000000000..1e1db8651e71
--- /dev/null
+++ b/dev-haskell/haddock/haddock-2.10.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.10.0.ebuild,v 1.1 2012/03/06 05:31:21 gienah Exp $
+
+EAPI="4"
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit haskell-cabal pax-utils
+
+DESCRIPTION="A documentation-generation tool for Haskell libraries"
+HOMEPAGE="http://www.haskell.org/haddock/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+# ia64 lost as we don't have ghc-7 there yet
+# ppc64 needs to be rekeyworded due to xhtml not being keyworded
+KEYWORDS="~alpha ~amd64 -ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-haskell/ghc-paths[profile?]
+ =dev-haskell/xhtml-3000.2*[profile?]
+ >=dev-lang/ghc-7.4"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"
+
+RESTRICT="test" # avoid depends on QC
+
+CABAL_EXTRA_BUILD_FLAGS="--ghc-options=-rtsopts"
+
+# haddock is disabled as Cabal seems to be buggy about building docs with itself.
+# however, other packages seem to work
+src_configure() {
+ # create a fake haddock executable. it'll set the right version to cabal
+ # configure, but will eventually get overwritten in src_compile by
+ # the real executable.
+ local exe="${S}/dist/build/haddock/haddock"
+ mkdir -p $(dirname "${exe}")
+ echo -e "#!/bin/sh\necho Haddock version ${PV}" > "${exe}"
+ chmod +x "${exe}"
+
+ haskell-cabal_src_configure --with-haddock="${exe}"
+}
+
+src_compile() {
+ # when building the (recursive..) haddock docs, change the datadir to the
+ # current directory, as we're using haddock inplace even if it's built to be
+ # installed into the system first.
+ haddock_datadir="${S}" haskell-cabal_src_compile
+}
+
+src_install() {
+ cabal_src_install
+ # haddock uses GHC-api to process TH source.
+ # TH requires GHCi which needs mmap('rwx') (bug #299709)
+ pax-mark -m "${D}/usr/bin/${PN}"
+}