summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-04-13 20:30:05 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-04-13 20:30:05 +0000
commita27b1f229ad20cc9f6e29bd2d5c6ba71a27629b4 (patch)
tree76c57e754a0806cb2fda379ff97fd2c8ab69aa22 /dev-haskell/timezone-olson
parentold (diff)
downloadhistorical-a27b1f229ad20cc9f6e29bd2d5c6ba71a27629b4.tar.gz
historical-a27b1f229ad20cc9f6e29bd2d5c6ba71a27629b4.tar.bz2
historical-a27b1f229ad20cc9f6e29bd2d5c6ba71a27629b4.zip
Initial version. A pure Haskell parser and renderer for binary Olson timezone files. Depend for x11-misc/xmobar-0.14
Package-Manager: portage-2.2.0_alpha96_p5/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/timezone-olson')
-rw-r--r--dev-haskell/timezone-olson/ChangeLog11
-rw-r--r--dev-haskell/timezone-olson/Manifest14
-rw-r--r--dev-haskell/timezone-olson/metadata.xml21
-rw-r--r--dev-haskell/timezone-olson/timezone-olson-0.1.2.ebuild26
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-haskell/timezone-olson/ChangeLog b/dev-haskell/timezone-olson/ChangeLog
new file mode 100644
index 000000000000..6084b5829f59
--- /dev/null
+++ b/dev-haskell/timezone-olson/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/timezone-olson
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/timezone-olson/ChangeLog,v 1.1 2012/04/13 20:30:05 slyfox Exp $
+
+*timezone-olson-0.1.2 (13 Apr 2012)
+
+ 13 Apr 2012; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +timezone-olson-0.1.2.ebuild:
+ Initial version. A pure Haskell parser and renderer for binary Olson timezone
+ files. Depend for x11-misc/xmobar-0.14
+
diff --git a/dev-haskell/timezone-olson/Manifest b/dev-haskell/timezone-olson/Manifest
new file mode 100644
index 000000000000..3897e6f4234f
--- /dev/null
+++ b/dev-haskell/timezone-olson/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST timezone-olson-0.1.2.tar.gz 11598 RMD160 24a92df2cb71d2a4ddc8a00841553962b6b6ee60 SHA1 891b5b94832e65036087ce7d354fbcce9245e7c4 SHA256 3ee1eb5401607750d328cc6ec3dc6b93f4290dc77e2d7f8f60629cbeefb5e0b6
+EBUILD timezone-olson-0.1.2.ebuild 894 RMD160 c3b9590dc0fb1f1cba0c5321036a34f3ca40f57e SHA1 29db62ac3871ee64e028124fddefc8e1590357b1 SHA256 29bb774453cb8658d18608fe2e9cdf0854dd335afcf22cbda9534ad55baf9751
+MISC ChangeLog 485 RMD160 8fdac05c35c4b4601c16d123bba35556f497f034 SHA1 f62d7a53fdd005e7aff527e6c196de782491c470 SHA256 d76f2c5267b542043255e337276f467872a8835da0f5ff76c754aa1e473202a7
+MISC metadata.xml 806 RMD160 9dfd2de971762b33603f61e69f9d2cd29771188f SHA1 5905f3cc68493dc2471d3a3c9057d2e18244099d SHA256 13b9b940419b41a05794d485b284f832bba9fa5047c4a7ec0c3d423af7261dd5
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEARECAAYFAk+Ijf4ACgkQcaHudmEf86pJPwCdH29JQe6pvWRS2j18GmHixIP+
+j4cAn0z1uJ1Tc9vquHQJ58GKJae6w5JF
+=qNFb
+-----END PGP SIGNATURE-----
diff --git a/dev-haskell/timezone-olson/metadata.xml b/dev-haskell/timezone-olson/metadata.xml
new file mode 100644
index 000000000000..5d90f2a01f88
--- /dev/null
+++ b/dev-haskell/timezone-olson/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A parser and renderer for binary Olson timezone
+ files whose format is specified by the tzfile(5)
+ man page on Unix-like systems. For more
+ information about this format, see
+ &lt;http://www.twinsun.com/tz/tz-link.htm&gt;. Functions
+ are provided for converting the parsed data into
+ &#39;TimeZoneSeries&#39; objects from the timezone-series
+ package. On many platforms, binary Olson timezone
+ files suitable for use with this package are
+ available in the directory /usr/share/zoneinfo
+ and its subdirectories on your computer.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/timezone-olson/timezone-olson-0.1.2.ebuild b/dev-haskell/timezone-olson/timezone-olson-0.1.2.ebuild
new file mode 100644
index 000000000000..e396ca6b7743
--- /dev/null
+++ b/dev-haskell/timezone-olson/timezone-olson-0.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/timezone-olson/timezone-olson-0.1.2.ebuild,v 1.1 2012/04/13 20:30:05 slyfox Exp $
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A pure Haskell parser and renderer for binary Olson timezone files"
+HOMEPAGE="http://projects.haskell.org/time-ng/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4.1[profile?] <dev-haskell/binary-0.6[profile?]
+ >=dev-haskell/time-1.1.4[profile?] <dev-haskell/time-1.5[profile?]
+ =dev-haskell/timezone-series-0.1*[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"