summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 06:37:37 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 06:37:37 +0000
commit6cd730d27cc1ca4bc373347acadd6229b7fa2a61 (patch)
tree592634048d2497bb3f7016cfb187d2c64a3b6578 /dev-haskell/uuid/uuid-1.3.3-r1.ebuild
parentBump unix-time to 0.2.2 (diff)
downloadhistorical-6cd730d27cc1ca4bc373347acadd6229b7fa2a61.tar.gz
historical-6cd730d27cc1ca4bc373347acadd6229b7fa2a61.tar.bz2
historical-6cd730d27cc1ca4bc373347acadd6229b7fa2a61.zip
Bump uuid to 1.3.3-r1
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x618E971F
Diffstat (limited to 'dev-haskell/uuid/uuid-1.3.3-r1.ebuild')
-rw-r--r--dev-haskell/uuid/uuid-1.3.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/uuid/uuid-1.3.3-r1.ebuild b/dev-haskell/uuid/uuid-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..0636ed078ff7
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/uuid/uuid-1.3.3-r1.ebuild,v 1.1 2013/12/11 06:37:27 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="http://projects.haskell.org/uuid/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/cryptohash-0.7:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.1:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ || ( ( >=dev-haskell/hashable-1.1.1.0:=[profile?] <dev-haskell/hashable-1.2.0:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.7
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"