summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-10-26 14:36:42 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-10-26 14:36:42 +0000
commitbfae0961df552660a73a876d3a0ffff86ba7872a (patch)
treee88ffcf3ebd4f1de5ac47769915505aea5bcbafc /dev-haskell
parentnew HOMEPAGE #68912 (diff)
downloadhistorical-bfae0961df552660a73a876d3a0ffff86ba7872a.tar.gz
historical-bfae0961df552660a73a876d3a0ffff86ba7872a.tar.bz2
historical-bfae0961df552660a73a876d3a0ffff86ba7872a.zip
Version bump.
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/gtk2hs/ChangeLog7
-rw-r--r--dev-haskell/gtk2hs/Manifest4
-rw-r--r--dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.61
-rw-r--r--dev-haskell/gtk2hs/gtk2hs-0.9.6.ebuild116
4 files changed, 126 insertions, 2 deletions
diff --git a/dev-haskell/gtk2hs/ChangeLog b/dev-haskell/gtk2hs/ChangeLog
index 6954d872ae89..2fae1bfb4507 100644
--- a/dev-haskell/gtk2hs/ChangeLog
+++ b/dev-haskell/gtk2hs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/gtk2hs
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.2 2004/06/24 22:14:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.3 2004/10/26 14:36:42 kosmikus Exp $
+
+*gtk2hs-0.9.6 (26 Oct 2004)
+
+ 26 Oct 2004; Andres Loeh <kosmikus@gentoo.org> gtk2hs-0.9.6.ebuild:
+ Version bump.
*gtk2hs-0.9.5 (17 May 2004)
diff --git a/dev-haskell/gtk2hs/Manifest b/dev-haskell/gtk2hs/Manifest
index 72cdd9b620b7..6d62d675fb7a 100644
--- a/dev-haskell/gtk2hs/Manifest
+++ b/dev-haskell/gtk2hs/Manifest
@@ -1,4 +1,6 @@
+MD5 f630df0130ccd8086ffd95bdb353346d gtk2hs-0.9.6.ebuild 3932
MD5 8e023ae1e205ac205cc17807eb74bbd5 gtk2hs-0.9.5.ebuild 2586
-MD5 75a9da34a0c1057b0f81fead3495e43b ChangeLog 358
+MD5 c29b739f12e8879a3d6242f5f1c3592a ChangeLog 474
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
MD5 2785816eabb8f055db732986a48f65fd files/digest-gtk2hs-0.9.5 64
+MD5 96674cbaf4f6bddf1517166b6e6f13a5 files/digest-gtk2hs-0.9.6 64
diff --git a/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.6 b/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.6
new file mode 100644
index 000000000000..8016e09cd9b1
--- /dev/null
+++ b/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.6
@@ -0,0 +1 @@
+MD5 fdd2d08d9789d1011b44a1df048c95b9 gtk2hs-0.9.6.tar.gz 457131
diff --git a/dev-haskell/gtk2hs/gtk2hs-0.9.6.ebuild b/dev-haskell/gtk2hs/gtk2hs-0.9.6.ebuild
new file mode 100644
index 000000000000..7922a7c6df69
--- /dev/null
+++ b/dev-haskell/gtk2hs/gtk2hs-0.9.6.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.6.ebuild,v 1.1 2004/10/26 14:36:42 kosmikus Exp $
+
+DESCRIPTION="GTK+-2.x bindings for Haskell"
+HOMEPAGE="http://gtk2hs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gtk2hs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="gnome"
+
+RDEPEND=">=virtual/ghc-5.04
+ >=x11-libs/gtk+-2
+ gnome? ( >=gnome-base/libglade-2
+ >=x11-libs/gtksourceview-0.6
+ >=gnome-base/gconf-2)"
+
+DEPEND="${RDEPEND}"
+
+# the variable ghc_version is used to store the ghc version
+# we are building against
+
+src_compile() {
+ # determine ghc library directory
+ # (so that it's possible to install the library for
+ # multiple versions of ghc)
+ local myopts
+ ghc_version=`best_version virtual/ghc | sed "s:.*/::"`
+ test -n ${ghc_version} && ghclibdir="/usr/lib/${ghc_version}"
+ test -n ${ghclibdir} || ghclibdir="/usr/lib"
+ test -n ${ghclibdir} && myopts="${myopts} --libdir=${D}${ghclibdir}"
+
+ # configure, override hc flags to not specify heap size
+ econf --with-hcflags="-O" \
+ `use_enable gnome gnome` \
+ `use_enable gnome libglade` \
+ ${myopts} \
+ || die "Configure failed"
+
+ #fix for bug in 0.9.6 tarball, directory missing so don't compile that demo
+ sed -i 's/MAKE_APPS += demo\/filechooser//' ${S}/Makefile
+ #or work out how to build without demos
+
+ # parallell build doesn't work, so specify -j1
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+
+ make install-without-pkg || die "Make install failed"
+
+ #the following actions are all for bug fixes:
+
+ # correct the package config files
+ sed -i "s:${D}::g" ${D}/${ghclibdir}/gtk2hs/*/*.conf
+
+ # build ghci .o files from .a files
+ ld -r -x -o ${D}/${ghclibdir}/gtk2hs/gtk2/gtk2hs.o \
+ --whole-archive ${D}/${ghclibdir}/gtk2hs/gtk2/libgtk2hs.a
+ ld -r -x -o ${D}/${ghclibdir}/gtk2hs/mogul/mogul.o \
+ --whole-archive ${D}/${ghclibdir}/gtk2hs/mogul/libmogul.a
+ [ `use gnome` ] && ld -r -x -o ${D}/${ghclibdir}/gtk2hs/sourceview/sourceview.o \
+ --whole-archive ${D}/${ghclibdir}/gtk2hs/sourceview/libsourceview.a
+ [ `use gnome` ] && ld -r -x -o ${D}/${ghclibdir}/gtk2hs/glade/glade2hs.o \
+ --whole-archive ${D}/${ghclibdir}/gtk2hs/glade/libglade2hs.a
+ [ `use gnome` ] && ld -r -x -o ${D}/${ghclibdir}/gtk2hs/gconf/gconf.o \
+ --whole-archive ${D}/${ghclibdir}/gtk2hs/gconf/libgconf.a
+
+ # fix dynamic linking with pthread bug for glade & sourview
+ sed -i 's:"pthread",::' ${D}/${ghclibdir}/gtk2hs/sourceview/sourceview.conf
+ sed -i 's:"pthread",::' ${D}/${ghclibdir}/gtk2hs/glade/glade.conf
+
+ # fix gconf hi file location install bug
+ mkdirhier ${D}/${ghclibdir}/gtk2hs/gconf/hi/System/Gnome/GConf
+ mv ${D}/${ghclibdir}/gtk2hs/gconf/hi/GConf.hi \
+ ${D}/${ghclibdir}/gtk2hs/gconf/hi/System/Gnome/
+ mv ${D}/${ghclibdir}/gtk2hs/gconf/hi/GConfClient.hi \
+ ${D}/${ghclibdir}/gtk2hs/gconf/hi/System/Gnome/GConf/
+ mv ${D}/${ghclibdir}/gtk2hs/gconf/hi/GConfType.hi \
+ ${D}/${ghclibdir}/gtk2hs/gconf/hi/System/Gnome/GConf/
+ mv ${D}/${ghclibdir}/gtk2hs/gconf/hi/GConfValue.hi \
+ ${D}/${ghclibdir}/gtk2hs/gconf/hi/System/Gnome/GConf/
+}
+
+pkg_postinst() {
+ register_ghc_packages
+}
+
+register_ghc_packages() {
+ einfo "Registering gtk2hs packages"
+ ghc-pkg -u -i ${ghclibdir}/gtk2hs/gtk2/gtk2.conf
+ ghc-pkg -u -i ${ghclibdir}/gtk2hs/mogul/mogul.conf
+ [ `use gnome` ] && ghc-pkg -u -i ${ghclibdir}/gtk2hs/sourceview/sourceview.conf
+ [ `use gnome` ] && ghc-pkg -u -i ${ghclibdir}/gtk2hs/glade/glade.conf
+ [ `use gnome` ] && ghc-pkg -u -i ${ghclibdir}/gtk2hs/gconf/gconf.conf
+}
+
+pkg_prerm() {
+ # check if another version is still there
+ has_version "<${CATEGORY}/${PF}" \
+ || has_version ">${CATEGORY}/${PF}" \
+ || unregister_ghc_packages
+}
+
+unregister_ghc_packages() {
+ einfo "Unregistering gtk2hs packages"
+ ghc-pkg -r gtk2
+ ghc-pkg -r mogul
+ ghc-pkg -r glade
+ ghc-pkg -r sourceview
+ ghc-pkg -r gconf
+}
+