summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-05-19 02:27:33 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-05-19 02:27:33 +0000
commit5b231082b158f04c169a4f7232dff7c65d46b5fa (patch)
tree42c0f4d1ef517b123554cbfe2b3b7b0d60591df9 /dev-java/commons-cli
parentMarked stable on hppa. (diff)
downloadhistorical-5b231082b158f04c169a4f7232dff7c65d46b5fa.tar.gz
historical-5b231082b158f04c169a4f7232dff7c65d46b5fa.tar.bz2
historical-5b231082b158f04c169a4f7232dff7c65d46b5fa.zip
Closes #51099
Diffstat (limited to 'dev-java/commons-cli')
-rw-r--r--dev-java/commons-cli/ChangeLog7
-rw-r--r--dev-java/commons-cli/Manifest8
-rw-r--r--dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff18
3 files changed, 25 insertions, 8 deletions
diff --git a/dev-java/commons-cli/ChangeLog b/dev-java/commons-cli/ChangeLog
index c8fec53de5bc..8c428aedb514 100644
--- a/dev-java/commons-cli/ChangeLog
+++ b/dev-java/commons-cli/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-cli
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/ChangeLog,v 1.10 2004/05/14 02:54:19 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/ChangeLog,v 1.11 2004/05/19 02:27:33 zx Exp $
+
+ 18 May 2004; Chris Aniszczyk <zx@gentoo.org>
+ files/commons-cli-1.0-gentoo.diff:
+ Fixed patch to allow unit testing to pass. Closes #51099
+ Thanks to Keith Burch <codemaestro@adelphia.net> for the patch.
*commons-cli-1.0-r4 (13 May 2004)
diff --git a/dev-java/commons-cli/Manifest b/dev-java/commons-cli/Manifest
index 3f6308d8a69e..36157fd45f72 100644
--- a/dev-java/commons-cli/Manifest
+++ b/dev-java/commons-cli/Manifest
@@ -1,5 +1,5 @@
-MD5 9af836edb3657dd5241a10f36f961521 files/commons-cli-1.0-gentoo.diff 4039
-MD5 8e1e3125e998bf49313b7e5ac3a5b1a0 files/digest-commons-cli-1.0-r4 62
-MD5 c7d8cc50cfc1dd9fbfa218ff116e3e7b ChangeLog 2019
+MD5 4c76b7018ee72e29f069669fe3e08b41 ChangeLog 2228
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
-MD5 5357b084dc4796730740447fc10371bf commons-cli-1.0-r4.ebuild 1471
+MD5 95f446fa65223e2901fc0cfe47083404 commons-cli-1.0-r4.ebuild 1470
+MD5 b534e655c6a40ff5b01098dddcda205c files/commons-cli-1.0-gentoo.diff 4407
+MD5 8e1e3125e998bf49313b7e5ac3a5b1a0 files/digest-commons-cli-1.0-r4 62
diff --git a/dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff b/dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff
index 9a916e774f8f..d7093de1e7bc 100644
--- a/dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff
+++ b/dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff
@@ -1,5 +1,5 @@
--- build.xml 2002-11-06 00:10:24.000000000 -0500
-+++ build.xml.patched 2004-05-13 22:46:32.819126973 -0400
++++ build.xml.patched 2004-05-14 16:22:54.196814648 -0400
@@ -1,15 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
@@ -64,7 +64,19 @@
<pathelement location="target/${final.name}.jar"></pathelement>
<pathelement path="${testclassesdir}"></pathelement>
</classpath>
-@@ -115,39 +113,17 @@
+@@ -79,10 +77,8 @@
+ <src>
+ <pathelement location="src/test"></pathelement>
+ </src>
++ <classpath refid="compile.classpath"/>
+ <classpath>
+- <fileset dir="lib">
+- <include name="*.jar"></include>
+- </fileset>
+ <pathelement location="target/${final.name}.jar"></pathelement>
+ </classpath>
+ </javac>
+@@ -115,39 +111,17 @@
<property name="title" value="CLI 1.0-beta-2-dev API"></property>
<javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="src/java" packagenames="org.apache.commons.cli.*">
@@ -106,7 +118,7 @@
<get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${maven.repo.remote}/maven/maven-install-latest.jar"></get>
<unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar"></unjar>
-@@ -155,4 +131,4 @@
+@@ -155,4 +129,4 @@
</target>
</project>