summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2005-12-27 01:48:56 +0000
committerJoshua Nichols <nichoj@gentoo.org>2005-12-27 01:48:56 +0000
commit25260a21ac18d1c5a3da400704d2569a9f8911a3 (patch)
tree690a83978492ecce7639eeb32681cf56ff7dd2f5 /dev-java/commons-grant
parentAdded mirrors for jpackage. (diff)
downloadhistorical-25260a21ac18d1c5a3da400704d2569a9f8911a3.tar.gz
historical-25260a21ac18d1c5a3da400704d2569a9f8911a3.tar.bz2
historical-25260a21ac18d1c5a3da400704d2569a9f8911a3.zip
Intial commit (bug #70893).
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'dev-java/commons-grant')
-rw-r--r--dev-java/commons-grant/ChangeLog11
-rw-r--r--dev-java/commons-grant/Manifest15
-rw-r--r--dev-java/commons-grant/commons-grant-1.0_beta5.ebuild55
-rw-r--r--dev-java/commons-grant/files/commons-grant-1.0_beta5-gentoo.diff38
-rw-r--r--dev-java/commons-grant/files/digest-commons-grant-1.0_beta51
-rw-r--r--dev-java/commons-grant/metadata.xml5
6 files changed, 125 insertions, 0 deletions
diff --git a/dev-java/commons-grant/ChangeLog b/dev-java/commons-grant/ChangeLog
new file mode 100644
index 000000000000..a1129e10395d
--- /dev/null
+++ b/dev-java/commons-grant/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/commons-grant
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-grant/ChangeLog,v 1.1 2005/12/27 01:48:56 nichoj Exp $
+
+*commons-grant-1.0_beta5 (27 Dec 2005)
+
+ 27 Dec 2005; Joshua Nichols <nichoj@gentoo.org>
+ +files/commons-grant-1.0_beta5-gentoo.diff, +metadata.xml,
+ +commons-grant-1.0_beta5.ebuild:
+ Intial commit (bug #70893).
+
diff --git a/dev-java/commons-grant/Manifest b/dev-java/commons-grant/Manifest
new file mode 100644
index 000000000000..b147f2837303
--- /dev/null
+++ b/dev-java/commons-grant/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 8f0ea8a6ab5a7e7828fcee013e218423 ChangeLog 434
+MD5 35d59cc366e70a5b86cf155c6e883ef5 commons-grant-1.0_beta5.ebuild 1620
+MD5 a05c0258c189c350524bb14761e9c3cd files/commons-grant-1.0_beta5-gentoo.diff 1254
+MD5 a6c7062575f989809e026a3b11529b73 files/digest-commons-grant-1.0_beta5 97
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDsJ0xndWRXhKOboURAsemAKCf/RiMakQatzb4rqvPUeU0Bfnm9gCfX2qp
+x7ABMUoj+LU7VNKWr54UBPs=
+=4fSk
+-----END PGP SIGNATURE-----
diff --git a/dev-java/commons-grant/commons-grant-1.0_beta5.ebuild b/dev-java/commons-grant/commons-grant-1.0_beta5.ebuild
new file mode 100644
index 000000000000..a36aa73d8ca9
--- /dev/null
+++ b/dev-java/commons-grant/commons-grant-1.0_beta5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-grant/commons-grant-1.0_beta5.ebuild,v 1.1 2005/12/27 01:48:56 nichoj Exp $
+
+# Note: Upstream is dead... only place to find is on the ibiblio maven repo
+# and on jpackage.org
+inherit java-pkg eutils rpm
+MY_PN="jakarta-${PN}"
+SNAPSHOT_DATE="20040118"
+MY_PV="${PV%%_*}.b5.cvs${SNAPSHOT_DATE}"
+MY_PV="${MY_PV//_beta/.b}"
+MY_P="${MY_PN}-${MY_PV}"
+JPACKAGE_REVISION="4"
+
+DESCRIPTION="A small collection of hacks to make using Ant in an embedded envinronment much easier."
+# This link seems dead, but I don't have anywhere else to turn
+HOMEPAGE="http://jakarta.apache.org/commons/sandbox/grant/"
+SRC_URI="mirror://jpackage/1.6/generic/free/SRPMS/${MY_P}-${JPACKAGE_REVISION}jpp.src.rpm"
+DEPEND=">=virtual/jdk-1.3
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )
+ dev-java/ant-core
+ dev-java/junit"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jikes source"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack(){
+ rpm_src_unpack
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ mkdir -p target/lib
+ cd target/lib
+ java-pkg_jar-from junit
+}
+
+src_compile(){
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags} || die "compile failed"
+}
+
+src_install(){
+ java-pkg_newjar target/${PN}-1.0-beta-4.jar ${PN}.jar
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
+
+src_test() {
+ ant test || die "Test failed"
+}
diff --git a/dev-java/commons-grant/files/commons-grant-1.0_beta5-gentoo.diff b/dev-java/commons-grant/files/commons-grant-1.0_beta5-gentoo.diff
new file mode 100644
index 000000000000..98e6a97965bd
--- /dev/null
+++ b/dev-java/commons-grant/files/commons-grant-1.0_beta5-gentoo.diff
@@ -0,0 +1,38 @@
+*** build.xml.orig Thu Nov 11 17:24:13 2004
+--- build.xml Thu Nov 11 17:25:02 2004
+***************
+*** 20,29 ****
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}">
+ </mkdir>
+! <condition property="noget">
+ <equals arg2="only" arg1="${build.sysclasspath}">
+ </equals>
+! </condition>
+ </target>
+ <target name="compile" description="o Compile the code" depends="get-deps">
+ <mkdir dir="${classesdir}">
+--- 20,30 ----
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}">
+ </mkdir>
+! <!--<condition property="noget">
+ <equals arg2="only" arg1="${build.sysclasspath}">
+ </equals>
+! </condition>-->
+! <property name="noget" value="true"></property>
+ </target>
+ <target name="compile" description="o Compile the code" depends="get-deps">
+ <mkdir dir="${classesdir}">
+***************
+*** 111,114 ****
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+! </project>
+\ No newline at end of file
+--- 112,115 ----
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+! </project>
diff --git a/dev-java/commons-grant/files/digest-commons-grant-1.0_beta5 b/dev-java/commons-grant/files/digest-commons-grant-1.0_beta5
new file mode 100644
index 000000000000..2e21d904a8e0
--- /dev/null
+++ b/dev-java/commons-grant/files/digest-commons-grant-1.0_beta5
@@ -0,0 +1 @@
+MD5 7eedc9fd3bd3f744fc82584acb3697f2 jakarta-commons-grant-1.0.b5.cvs20040118-4jpp.src.rpm 11651
diff --git a/dev-java/commons-grant/metadata.xml b/dev-java/commons-grant/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-grant/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>