summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-10-02 22:13:28 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-10-02 22:13:28 +0000
commit40cfce62098075b88769f28baa419719f5af9a29 (patch)
treeed2c26d427bd8de667b517fadd5f6ba106958fe4 /dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild
parentWork around gettext-0.18.3.1 causing sandbox failures in eautoreconf (bug #48... (diff)
downloadhistorical-40cfce62098075b88769f28baa419719f5af9a29.tar.gz
historical-40cfce62098075b88769f28baa419719f5af9a29.tar.bz2
historical-40cfce62098075b88769f28baa419719f5af9a29.zip
New package for dev-java/felix-gogo-runtime, Felix Gogo Runtime. Indirect dependency needed for Struts 2.
Package-Manager: portage-HEAD/cvs/Linux x86_64 Manifest-Sign-Key: 0x6D34E57D
Diffstat (limited to 'dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild')
-rw-r--r--dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild b/dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild
new file mode 100644
index 000000000000..35ed78f784e0
--- /dev/null
+++ b/dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild,v 1.1 2013/10/02 22:13:23 tomwij Exp $
+
+EAPI="5"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="Felix Gogo Runtime"
+HOMEPAGE="http://felix.apache.org/site/apache-felix-gogo.html"
+LICENSE="Apache-2.0"
+
+MY_PN="org.apache.felix.gogo.runtime"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://apache/felix/${MY_P}-project.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/osgi-compendium:0
+ dev-java/osgi-core-api:0"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ epatch "${FILESDIR}"/${P}-event-properties-to-map.patch
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_compile() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only osgi-core-api osgi-core-api.jar):$(java-pkg_getjar --build-only osgi-compendium osgi-compendium.jar)"
+
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-osgi_newjar "${S}"/target/${MY_P}.jar ${MY_PN} ${MY_PN} "Export-Package: ${MY_PN}"
+}