summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2014-07-14 18:46:04 +0000
committerRalph Sennhauser <sera@gentoo.org>2014-07-14 18:46:04 +0000
commit41364ac2607bc7d577cff6f807226c746d4c2923 (patch)
tree85982bb52dc1822094f735ccf6905f6987829bbd /dev-java/gcj-jdk/gcj-jdk-4.8.2.ebuild
parentVersion bump. (diff)
downloadhistorical-41364ac2607bc7d577cff6f807226c746d4c2923.tar.gz
historical-41364ac2607bc7d577cff6f807226c746d4c2923.tar.bz2
historical-41364ac2607bc7d577cff6f807226c746d4c2923.zip
Add missing versions for 4.7 and 4.8
Fix 4.7.3 to be able to build ant-core-1.9 #489266 Thanks to Andrew John Hughes <gnu_andrew@member.fsf.org> for the javac wrapper und for providing new API diffs Drop 4.5 and 4.6 as they are to old to build current icedtea:7 Drop ia64 ppc ppc64 on 4.8 as the correspondig gcc is missing those keywords Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0x3C5CF75A
Diffstat (limited to 'dev-java/gcj-jdk/gcj-jdk-4.8.2.ebuild')
-rw-r--r--dev-java/gcj-jdk/gcj-jdk-4.8.2.ebuild110
1 files changed, 110 insertions, 0 deletions
diff --git a/dev-java/gcj-jdk/gcj-jdk-4.8.2.ebuild b/dev-java/gcj-jdk/gcj-jdk-4.8.2.ebuild
new file mode 100644
index 000000000000..303d33b779e0
--- /dev/null
+++ b/dev-java/gcj-jdk/gcj-jdk-4.8.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gcj-jdk/gcj-jdk-4.8.2.ebuild,v 1.1 2014/07/14 18:45:53 sera Exp $
+
+EAPI="5"
+
+inherit java-vm-2 multilib
+
+DESCRIPTION="Java wrappers around GCJ"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86 ~x86-linux"
+SLOT="0"
+IUSE="X"
+
+ECJ_GCJ_SLOT="4.2"
+API_DIFF_PV="${PV}"
+
+# perl is needed for javac wrapper
+RDEPEND="
+ dev-java/ecj-gcj:${ECJ_GCJ_SLOT}
+ dev-lang/perl
+ ~sys-devel/gcc-${PV}[gcj]
+ X? ( ~sys-devel/gcc-${PV}[awt] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ # jre lib paths ...
+ local libarch="$(get_system_arch)"
+ local gcc_version=${PV}
+ local gccbin=$(gcc-config -B ${gcc_version})
+ gccbin=${gccbin#"${EPREFIX}"}
+ local gcclib=$(gcc-config -L ${gcc_version} | cut -d':' -f1)
+ gcclib=${gcclib#"${EPREFIX}"}
+ local gcjhome="/usr/$(get_libdir)/${P}"
+ local gccchost="${CHOST}"
+ local gcjlibdir=$(echo "${EPREFIX}"/usr/$(get_libdir)/gcj-${gcc_version}-*)
+ gcjlibdir=${gcjlibdir#"${EPREFIX}"}
+
+ # links
+ dodir ${gcjhome}/bin
+ dodir ${gcjhome}/jre/bin
+ dosym ${gccbin}/gij ${gcjhome}/bin/java
+ dosym ${gccbin}/gij ${gcjhome}/jre/bin/java
+ dosym ${gccbin}/gjar ${gcjhome}/bin/jar
+ dosym ${gccbin}/gjdoc ${gcjhome}/bin/javadoc
+ dosym ${gccbin}/grmic ${gcjhome}/bin/rmic
+ dosym ${gccbin}/gjavah ${gcjhome}/bin/javah
+ dosym ${gccbin}/jcf-dump ${gcjhome}/bin/javap
+ dosym ${gccbin}/gappletviewer ${gcjhome}/bin/appletviewer
+ dosym ${gccbin}/gjarsigner ${gcjhome}/bin/jarsigner
+ dosym ${gccbin}/grmiregistry ${gcjhome}/bin/rmiregistry
+ dosym ${gccbin}/grmiregistry ${gcjhome}/jre/bin/rmiregistry
+ dosym ${gccbin}/gkeytool ${gcjhome}/bin/keytool
+ dosym ${gccbin}/gkeytool ${gcjhome}/jre/bin/keytool
+ dosym ${gccbin}/gnative2ascii ${gcjhome}/bin/native2ascii
+ dosym ${gccbin}/gorbd ${gcjhome}/bin/orbd
+ dosym ${gccbin}/gorbd ${gcjhome}/jre/bin/orbd
+ dosym ${gccbin}/grmid ${gcjhome}/bin/rmid
+ dosym ${gccbin}/grmid ${gcjhome}/jre/bin/rmid
+ dosym ${gccbin}/gserialver ${gcjhome}/bin/serialver
+ dosym ${gccbin}/gtnameserv ${gcjhome}/bin/tnameserv
+ dosym ${gccbin}/gtnameserv ${gcjhome}/jre/bin/tnameserv
+
+ dodir ${gcjhome}/jre/lib/${libarch}/client
+ dodir ${gcjhome}/jre/lib/${libarch}/server
+ dosym ${gcjlibdir}/libjvm.so ${gcjhome}/jre/lib/${libarch}/client/libjvm.so
+ dosym ${gcjlibdir}/libjvm.so ${gcjhome}/jre/lib/${libarch}/server/libjvm.so
+ use X && dosym ${gcjlibdir}/libjawt.so ${gcjhome}/jre/lib/${libarch}/libjawt.so
+
+ dosym /usr/share/gcc-data/${gccchost}/${gcc_version}/java/libgcj-${gcc_version/_/-}.jar \
+ ${gcjhome}/jre/lib/rt.jar
+ dodir ${gcjhome}/lib
+ dosym /usr/share/gcc-data/${gccchost}/${gcc_version}/java/libgcj-tools-${gcc_version/_/-}.jar \
+ ${gcjhome}/lib/tools.jar
+ dosym ${gcclib}/include ${gcjhome}/include
+
+ local ecj_jar="$(readlink "${EPREFIX}"/usr/share/eclipse-ecj/ecj.jar)"
+ exeinto ${gcjhome}/bin
+ sed -e "s#@JAVA@#${gcjhome}/bin/java#" \
+ -e "s#@ECJ_JAR@#${ecj_jar}#" \
+ -e "s#@RT_JAR@#${gcjhome}/jre/lib/rt.jar#" \
+ -e "s#@TOOLS_JAR@#${gcjhome}/lib/tools.jar#" \
+ "${FILESDIR}"/javac.in \
+ | newexe - javac
+ assert
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Do not set as system VM (see below)
+ # java-vm-2_pkg_postinst
+
+ ewarn "gcj does not currently provide all the 1.5 or 1.6 APIs."
+ ewarn "See http://fuseyism.com/japi/ibmjdk15-libgcj-${API_DIFF_PV}.html"
+ ewarn "and http://fuseyism.com/japi/icedtea6-libgcj-${API_DIFF_PV}.html"
+ ewarn "Check for existing bugs relating to missing APIs and file"
+ ewarn "new ones at http://gcc.gnu.org/bugzilla/"
+ ewarn
+ ewarn "Due to this and limited manpower, we currently cannot support"
+ ewarn "using gcj-jdk as a system VM. Its main purpose is to bootstrap"
+ ewarn "IcedTea without prior binary VM installation. To do that, execute:"
+ ewarn
+ ewarn "emerge -o icedtea && emerge icedtea"
+}