summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-12 19:44:58 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-12 19:44:58 +0000
commitea712162083696eed2614717489b585074c5fd2b (patch)
treec43e3722e2becd4ef926adb0fb0110529049d81f /dev-java/jcommon
parentMarked ppc stable, thanks bambam. (diff)
downloadhistorical-ea712162083696eed2614717489b585074c5fd2b.tar.gz
historical-ea712162083696eed2614717489b585074c5fd2b.tar.bz2
historical-ea712162083696eed2614717489b585074c5fd2b.zip
Style fixes
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-java/jcommon')
-rw-r--r--dev-java/jcommon/Manifest10
-rw-r--r--dev-java/jcommon/jcommon-0.9.7-r1.ebuild11
-rw-r--r--dev-java/jcommon/jcommon-0.9.7.ebuild11
3 files changed, 26 insertions, 6 deletions
diff --git a/dev-java/jcommon/Manifest b/dev-java/jcommon/Manifest
index b820a0d749de..c5284448d4f2 100644
--- a/dev-java/jcommon/Manifest
+++ b/dev-java/jcommon/Manifest
@@ -1,6 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 744e9d2f308be10b4de15ab3a5ea883c jcommon-0.9.7.ebuild 958
MD5 f4f0ee8a5fcdb330ddcec8073a9e146b jcommon-0.9.7-r1.ebuild 974
MD5 2475d9e2894a01863de1bc83cf18ee15 ChangeLog 1267
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 8eaa092f9e56aa5c625aad517d4b9887 files/digest-jcommon-0.9.7 65
MD5 8eaa092f9e56aa5c625aad517d4b9887 files/digest-jcommon-0.9.7-r1 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC1B3W/rLF9B432nYRAob4AJwIsaeartXcI5/kHwFqCJYEbsXLJgCeK5Rs
+4GMLAP2HcBO8FAXyumlwIj4=
+=9lrO
+-----END PGP SIGNATURE-----
diff --git a/dev-java/jcommon/jcommon-0.9.7-r1.ebuild b/dev-java/jcommon/jcommon-0.9.7-r1.ebuild
index 219eeea53c4c..9fbec9a6a98c 100644
--- a/dev-java/jcommon/jcommon-0.9.7-r1.ebuild
+++ b/dev-java/jcommon/jcommon-0.9.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/jcommon-0.9.7-r1.ebuild,v 1.1 2005/05/18 11:21:26 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/jcommon-0.9.7-r1.ebuild,v 1.2 2005/07/12 19:44:58 axxo Exp $
inherit java-pkg
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.jfree.org"
SRC_URI="mirror://sourceforge/jfreechart/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc x86"
IUSE="doc jikes"
DEPEND=">=virtual/jdk-1.3
dev-java/ant
@@ -17,8 +17,13 @@ DEPEND=">=virtual/jdk-1.3
jikes? ( dev-java/jikes )"
RDEPEND=">=virtual/jdk-1.3"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
rm -f junit/*
+}
+
+src_compile() {
local antflags="compile javadoc"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant -f ant/build.xml ${antflags} || die "compile failed"
diff --git a/dev-java/jcommon/jcommon-0.9.7.ebuild b/dev-java/jcommon/jcommon-0.9.7.ebuild
index 70d92b44a0ac..65dfb1a0e978 100644
--- a/dev-java/jcommon/jcommon-0.9.7.ebuild
+++ b/dev-java/jcommon/jcommon-0.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/jcommon-0.9.7.ebuild,v 1.4 2005/05/14 20:47:47 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/jcommon-0.9.7.ebuild,v 1.5 2005/07/12 19:44:58 axxo Exp $
inherit java-pkg
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.jfree.org"
SRC_URI="mirror://sourceforge/jfreechart/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="x86 ppc amd64"
+KEYWORDS="amd64 ppc x86"
IUSE="doc jikes"
DEPEND=">=virtual/jdk-1.3
dev-java/ant
@@ -17,8 +17,13 @@ DEPEND=">=virtual/jdk-1.3
jikes? ( dev-java/jikes )"
RDEPEND=">=virtual/jdk-1.3"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
rm -f junit/*
+}
+
+src_compile() {
local antflags="compile javadoc"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant -f ant/build.xml ${antflags} || die "compile failed"