summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-06-10 15:23:35 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-06-10 15:23:35 +0000
commit5890767b4d9eb1b735761b99f45a0cc86637499f (patch)
tree3aeaf16ae3f09d4a223be0eda15da268f027d726 /dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.3.ebuild
parentmake configure executable (diff)
downloadhistorical-5890767b4d9eb1b735761b99f45a0cc86637499f.tar.gz
historical-5890767b4d9eb1b735761b99f45a0cc86637499f.tar.bz2
historical-5890767b4d9eb1b735761b99f45a0cc86637499f.zip
Fix ebuild when nls or ons use flag is off.
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.3.ebuild')
-rw-r--r--dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.3.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.3.ebuild b/dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.3.ebuild
index 209c5cbb32cb..7b2ebb08ddd7 100644
--- a/dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.3.ebuild
+++ b/dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.3.ebuild,v 1.1 2007/06/09 21:23:59 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-oracle-bin/jdbc-oracle-bin-10.2.0.3.ebuild,v 1.2 2007/06/10 15:23:35 betelgeuse Exp $
inherit java-pkg-2
@@ -97,8 +97,14 @@ pkg_nofetch() {
src_unpack() {
determine_files
cp "${DISTDIR}/${file_main_used}" ${PN}.jar || die
- use nls && cp "${DISTDIR}/${file_nls}" ${file_nls_orig} || die
- use ons && cp "${DISTDIR}/${file_ons}" ${file_ons_orig} || die
+
+ if use nls; then
+ cp "${DISTDIR}/${file_nls}" ${file_nls_orig} || die
+ fi
+
+ if use ons; then
+ cp "${DISTDIR}/${file_ons}" ${file_ons_orig} || die
+ fi
if use doc; then
mkdir "${S}/javadoc" && cd "${S}/javadoc"