summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2008-07-18 19:31:15 +0000
committerSerkan Kaba <serkan@gentoo.org>2008-07-18 19:31:15 +0000
commita3a39e9d32e590b2e601414c9a969355d6a499bb (patch)
treef2b6ed3191796301e22617b1d8da89be3fcf5128 /dev-java/libmatthew-java/files
parentia64/sparc/x86 stable (diff)
downloadhistorical-a3a39e9d32e590b2e601414c9a969355d6a499bb.tar.gz
historical-a3a39e9d32e590b2e601414c9a969355d6a499bb.tar.bz2
historical-a3a39e9d32e590b2e601414c9a969355d6a499bb.zip
Initial ebuild. Fixes bug #161680.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.24-gentoo-r8 x86_64
Diffstat (limited to 'dev-java/libmatthew-java/files')
-rw-r--r--dev-java/libmatthew-java/files/libmatthew-java-0.7.1-makefile-fixes.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/libmatthew-java/files/libmatthew-java-0.7.1-makefile-fixes.patch b/dev-java/libmatthew-java/files/libmatthew-java-0.7.1-makefile-fixes.patch
new file mode 100644
index 000000000000..a7494ebfea67
--- /dev/null
+++ b/dev-java/libmatthew-java/files/libmatthew-java-0.7.1-makefile-fixes.patch
@@ -0,0 +1,26 @@
+diff -Nur libmatthew-java-0.7.1/Makefile libmatthew-java-0.7.1_patched/Makefile
+--- libmatthew-java-0.7.1/Makefile 2008-04-26 15:35:13.000000000 +0300
++++ libmatthew-java-0.7.1_patched/Makefile 2008-07-02 22:55:58.000000000 +0300
+@@ -6,7 +6,7 @@
+ CC?=gcc
+ LD?=ld
+ PPFLAGS+=-C -P
+-CFLAGS+=-fpic -Wall -Os -pedantic -std=c99 -Werror
++CFLAGS+=-fPIC -Wall -pedantic -std=c99
+ GCJFLAGS+=-fjni
+ JCFLAGS+=-source 5.0
+ INCLUDES+=-I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux
+@@ -57,12 +57,7 @@
+ io-$(IOVER).jar: .classes
+ (cd classes; $(JAR) cf ../$@ cx/ath/matthew/io/*class)
+ unix-$(UNIXVER).jar: .classes
+-ifeq ($(DEBUG),enable)
+- echo "Class-Path: $(JARDIR)/debug-$(DEBUG).jar" > Manifest
+-else
+- echo "Class-Path: " > Manifest
+-endif
+- (cd classes; $(JAR) cfm ../$@ ../Manifest cx/ath/matthew/unix/*class)
++ (cd classes; $(JAR) cf ../$@ cx/ath/matthew/unix/*class)
+
+ hexdump-$(HEXVER).jar: .classes
+ (cd classes; $(JAR) cf ../$@ cx/ath/matthew/utils/Hexdump.class)