summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-01-22 03:41:50 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-01-22 03:41:50 +0000
commit27fe4b07f13885ec679ffb83f09fb443ec9f0b7e (patch)
tree60d29a87cc9b704be35b20ebb51f280abf071c03 /dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild
parentStable on x86 for bug #119634; Stabilize Gnome-2.12.2 (diff)
downloadhistorical-27fe4b07f13885ec679ffb83f09fb443ec9f0b7e.tar.gz
historical-27fe4b07f13885ec679ffb83f09fb443ec9f0b7e.tar.bz2
historical-27fe4b07f13885ec679ffb83f09fb443ec9f0b7e.zip
Initial commit. Needed to build oscore from source (bug #63282).
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild')
-rw-r--r--dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild b/dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild
new file mode 100644
index 000000000000..c72ea287bdca
--- /dev/null
+++ b/dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild,v 1.1 2006/01/22 03:41:50 nichoj Exp $
+
+inherit java-pkg versionator
+
+MY_PN=ejb
+MY_PV=$(replace_all_version_separators _)
+MY_P="${MY_PN}-${MY_PV}"
+At="${MY_P}-fr-spec-api.zip"
+DESCRIPTION="Sun's Enterprise Java Beans specification"
+HOMEPAGE="http://java.sun.com/products/ejb/"
+SRC_URI="${At}"
+DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=ejb-${PV}-fr-class-oth-JSpec&SiteId=JSC&TransactionId=noreg"
+
+LICENSE="sun-ejb-spec-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND="app-arch/unzip"
+RESTRICT="fetch"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from the following URL and place it in ${DISTDIR}:"
+ einfo "${DOWNLOAD_URL}"
+ einfo "The link is found under '2.1 Final Release', next to 'Download Class Files'"
+}
+
+
+src_install() {
+ java-pkg_newjar ${MY_P}-api.jar ${MY_PN}-api.jar
+}