summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-10-18 19:25:14 +0000
committerAron Griffis <agriffis@gentoo.org>2005-10-18 19:25:14 +0000
commit4ab43aaa11dc7bbbcb08e9daf24b51df5a3b0239 (patch)
treef9714340fe3c102bb2e07cab72fc0f2dee0e760d /dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
parentFixed compilation problem with missing inttypes.h. (diff)
downloadhistorical-4ab43aaa11dc7bbbcb08e9daf24b51df5a3b0239.tar.gz
historical-4ab43aaa11dc7bbbcb08e9daf24b51df5a3b0239.tar.bz2
historical-4ab43aaa11dc7bbbcb08e9daf24b51df5a3b0239.zip
Respect the global USE=nsplugin instead of the local USE=browserplugin
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild')
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
index da2231c4c00e..ee19fa620e56 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild,v 1.9 2005/09/30 15:34:19 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild,v 1.10 2005/10/18 19:25:14 agriffis Exp $
inherit java eutils
@@ -20,7 +20,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="doc browserplugin jce mozilla"
+IUSE="doc nsplugin jce mozilla"
#glibc dep: #102423
DEPEND=">=dev-java/java-config-1.1.5
@@ -116,7 +116,7 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use browserplugin || use mozilla; then
+ if use nsplugin || use mozilla; then
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -189,9 +189,9 @@ pkg_postinst() {
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use browserplugin && use mozilla; then
+ if ! use nsplugin && use mozilla; then
ewarn
ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'browserplugin' please update your USE"
+ ewarn "has been renamed to 'nsplugin' please update your USE"
fi
}