summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-04-18 08:30:14 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-04-18 08:30:14 +0000
commit2462e3453785e47aff4057e08129dcaa5a37e179 (patch)
tree4d9c5d494d007711fe22bab7f64f562b703d6235 /dev-java/xjavac/xjavac-20041208-r5.ebuild
parentfix manifest (diff)
downloadhistorical-2462e3453785e47aff4057e08129dcaa5a37e179.tar.gz
historical-2462e3453785e47aff4057e08129dcaa5a37e179.tar.bz2
historical-2462e3453785e47aff4057e08129dcaa5a37e179.zip
Add dev-java/ant-core to RDEPEND for bug #174981. ant-core should not be --build-only because xjavac calls into ant-core.
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'dev-java/xjavac/xjavac-20041208-r5.ebuild')
-rw-r--r--dev-java/xjavac/xjavac-20041208-r5.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-java/xjavac/xjavac-20041208-r5.ebuild b/dev-java/xjavac/xjavac-20041208-r5.ebuild
index 6a361352e396..a84eb4b8b631 100644
--- a/dev-java/xjavac/xjavac-20041208-r5.ebuild
+++ b/dev-java/xjavac/xjavac-20041208-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r5.ebuild,v 1.3 2007/04/18 06:02:36 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r5.ebuild,v 1.4 2007/04/18 08:30:14 betelgeuse Exp $
# Does not install a symlink any more so ANT_TASKS is the only way to use this
WANT_SPLIT_ANT="true"
@@ -14,7 +14,8 @@ LICENSE="Apache-2.0"
SLOT="1"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
DEPEND=">=virtual/jdk-1.4"
-RDEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.7"
src_unpack() {
unpack ${A}
@@ -26,7 +27,7 @@ src_unpack() {
}
src_compile() {
- eant jar -Dclasspath=$(java-pkg_getjars --build-only ant-core)
+ eant jar -Dclasspath=$(java-pkg_getjars ant-core)
}
src_install() {