summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-22 12:08:29 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-22 12:08:29 +0000
commit6977a72f93444548f2871c06201580c92957065b (patch)
tree0542cc3a58d2f3b26d69c26eb4fe41ca36cacb71 /dev-java
parentInitial import. Keywords ~x86. (diff)
downloadhistorical-6977a72f93444548f2871c06201580c92957065b.tar.gz
historical-6977a72f93444548f2871c06201580c92957065b.tar.bz2
historical-6977a72f93444548f2871c06201580c92957065b.zip
Changed to support jakarta-commons eclass and 'doc' USE flag. Keywords ~x86.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-lang/ChangeLog8
-rw-r--r--dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild24
-rw-r--r--dev-java/commons-lang/files/digest-commons-lang-1.0.1-r11
3 files changed, 32 insertions, 1 deletions
diff --git a/dev-java/commons-lang/ChangeLog b/dev-java/commons-lang/ChangeLog
index ea3aa6cc2ff6..489f7c2c6236 100644
--- a/dev-java/commons-lang/ChangeLog
+++ b/dev-java/commons-lang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-lang
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/ChangeLog,v 1.7 2003/02/12 05:51:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/ChangeLog,v 1.8 2003/03/22 12:08:29 absinthe Exp $
+
+*commons-lang-1.0.1-r1 (22 Mar 2003)
+
+ 22 Mar 2003; Dylan Carlson <absinthe@gentoo.org>
+ commons-lang-1.0.1-r1.ebuild:
+ Changed to use jakarta-commons eclass. 'doc' USE flag added.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild b/dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..a157c741f5b7
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild,v 1.1 2003/03/22 12:08:29 absinthe Exp $
+
+inherit jakarta-commons
+
+S="${WORKDIR}/${PN}-${PV}-src/lang"
+DESCRIPTION="Jakarta components to manipulate core java classes"
+HOMEPAGE="http://jakarta.apache.org/commons/lang.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ junit? ( >=dev-java/junit-3.7 )"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes junit"
+
+src_compile() {
+ cp LICENSE.txt ../LICENSE
+ jakarta-commons_src_compile myconf make
+ use doc && jakarta-commons_src_compile makedoc
+}
diff --git a/dev-java/commons-lang/files/digest-commons-lang-1.0.1-r1 b/dev-java/commons-lang/files/digest-commons-lang-1.0.1-r1
new file mode 100644
index 000000000000..6278d25a7730
--- /dev/null
+++ b/dev-java/commons-lang/files/digest-commons-lang-1.0.1-r1
@@ -0,0 +1 @@
+MD5 7217632e6a7f18770734128baba273c2 commons-lang-1.0.1-src.tar.gz 96843