summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-12-17 01:40:19 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-12-17 01:40:19 +0000
commit6d3e388810fe618006f6fb7b1dba36515aa3ff93 (patch)
treec20d07d64ef656062e8c405f7d2d3ab04f2801a9 /dev-lang/fpc-ide/fpc-ide-2.0.2.ebuild
parentVersion bump. Add ~x86 keyword. (diff)
downloadhistorical-6d3e388810fe618006f6fb7b1dba36515aa3ff93.tar.gz
historical-6d3e388810fe618006f6fb7b1dba36515aa3ff93.tar.bz2
historical-6d3e388810fe618006f6fb7b1dba36515aa3ff93.zip
version bump
Package-Manager: portage-2.0.53
Diffstat (limited to 'dev-lang/fpc-ide/fpc-ide-2.0.2.ebuild')
-rw-r--r--dev-lang/fpc-ide/fpc-ide-2.0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lang/fpc-ide/fpc-ide-2.0.2.ebuild b/dev-lang/fpc-ide/fpc-ide-2.0.2.ebuild
new file mode 100644
index 000000000000..1eaef3a46bf1
--- /dev/null
+++ b/dev-lang/fpc-ide/fpc-ide-2.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/fpc-ide-2.0.2.ebuild,v 1.1 2005/12/17 01:40:19 carlo Exp $
+
+
+S="${WORKDIR}/fpc"
+
+DESCRIPTION="Free Pascal Compiler Integrated Development Environment"
+HOMEPAGE="http://www.freepascal.org/"
+SRC_URI="mirror://sourceforge/freepascal/fpc-${PV}.source.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1 LGPL-2.1-FPC"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="~dev-lang/fpc-2.0.2
+ sys-libs/gpm"
+
+src_compile () {
+ make -j1 -C ide all || die "make ide failed!"
+}
+
+src_install () {
+ make ide_install INSTALL_PREFIX=${D}usr || die "make ide_install failed!"
+}