summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2010-12-18 10:17:27 +0000
committerAlistair Bush <ali_bush@gentoo.org>2010-12-18 10:17:27 +0000
commit7e29338d2424fbba708325599a6c9e3a228e09b1 (patch)
tree6fea7d60a929b16dbe9e52fdbf61aac6fceaaa25 /dev-lang/mono
parentfix wrong email address (diff)
downloadhistorical-7e29338d2424fbba708325599a6c9e3a228e09b1.tar.gz
historical-7e29338d2424fbba708325599a6c9e3a228e09b1.tar.bz2
historical-7e29338d2424fbba708325599a6c9e3a228e09b1.zip
Cleanup -9999 ebuild. fix build.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/Manifest2
-rw-r--r--dev-lang/mono/mono-9999.ebuild23
2 files changed, 15 insertions, 10 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index ceb741f72e7a..9a4440b4b9bd 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -9,6 +9,6 @@ DIST mono-2.6.7.tar.bz2 27921963 RMD160 5825ad284e4123e4ddb8933637a3dbf5f57f7f5a
DIST mono-2.8.1.tar.bz2 31181201 RMD160 1d3c2a71fa46fcb93f201cdce2a19407cb1cd2ef SHA1 c46f9d8282803e8fd137acdb126e34421762b13c SHA256 ca4cc1b3f69458c3d8793b6694df51205f8b2cb3e8086d3986e753f7197e0da1
EBUILD mono-2.6.7.ebuild 7564 RMD160 e83f25ce2d6bb38ecba81d86e96958a5ea7567d7 SHA1 a12f62b9decdc1c6ed93b6c6fbe4659d16e8074f SHA256 e8cbfd812e094cdd45149873461e5618be424219b5a6b7251e6f1d4371a09fed
EBUILD mono-2.8.1-r1.ebuild 7720 RMD160 decb755cab713361f392ece3b71c97660ae15937 SHA1 cbc774f0ddad944481540c060754f769bba89068 SHA256 3b42688e653d16a5f8e320f3c4c9a537521c6ab7fd46b0445a66a168638791ee
-EBUILD mono-9999.ebuild 7853 RMD160 5a838495d09bb4fcdcfc6077c60bc1c7917fd2d2 SHA1 767925f8137f19f156bad600a056a3c6b76b6a15 SHA256 a64eb6185976d027c541a4ef530297441203f8ea23ebfb111630a159d24a176d
+EBUILD mono-9999.ebuild 8024 RMD160 bd642a94933167190744f0496b7ed667d6db67ea SHA1 6905879a095f87ccf4d7f92a7f0082fc7c9f6c96 SHA256 2c7634db7751dd1b664954d9aedad657db242417eb46f9a54b91080fe3540235
MISC ChangeLog 43932 RMD160 e19f43acc751fe589a1411d2df2646e89709205a SHA1 3dfe42a0c5d50d1a002a3cea843ebfcf9fb9c9bc SHA256 56f69aed9d713f5a265e8fe7a674f99e7a624a7550c76ecb427bb33943f20330
MISC metadata.xml 484 RMD160 862882f919ccc94b3fbdcdb6d6218b0969fec187 SHA1 42a61b9a60f03068d6601262f26e5a6fde463022 SHA256 2953e2de5e3ec6d0a69e9b8e145e0b27fb43dc7e3d59ef6a546c15fbc960631d
diff --git a/dev-lang/mono/mono-9999.ebuild b/dev-lang/mono/mono-9999.ebuild
index f26845939f1f..90ce910352b2 100644
--- a/dev-lang/mono/mono-9999.ebuild
+++ b/dev-lang/mono/mono-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-9999.ebuild,v 1.4 2010/10/05 21:22:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-9999.ebuild,v 1.5 2010/12/18 10:17:27 ali_bush Exp $
EAPI=2
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.go-mono.com"
LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
SLOT="0"
KEYWORDS=""
-IUSE="hardened xen moonlight minimal"
+IUSE="hardened xen minimal"
#Bash requirement is for += operator
COMMONDEPEND="!<dev-dotnet/pnet-0.6.12
@@ -89,20 +89,25 @@ src_configure() {
#Remove this at your own peril. Mono will barf in unexpected ways.
append-flags -fno-strict-aliasing
- #NOTE: We need the static libs for now so mono-debugger works.
- #See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
-
- #--with-glib=system configure: error: --with-glib=system is no longer supported as of Mono 2.8
- #--static_mono=yes (default anyway)
+ # NOTE: We need the static libs for now so mono-debugger works.
+ # See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
+ #
+ # --without-moonlight since www-plugins/moonlight is not the only one
+ # using mono: https://bugzilla.novell.com/show_bug.cgi?id=641005#c3
+ #
+ # --with-profile4 needs to be always enabled since it's used by default
+ # and, otherwise, problems like bug #340641 appear.
go-mono_src_configure \
+ --enable-static \
--disable-quiet-build \
- $(use_with moonlight) \
+ --without-moonlight \
--with-libgdiplus=$(use minimal && printf "no" || printf "installed" ) \
$(use_with xen xen_opt) \
--without-ikvm-native \
--with-jit \
- --disable-dtrace
+ --disable-dtrace \
+ --with-profile4
}
src_test() {