summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-06-01 16:17:05 +0000
committerMatti Bickel <mabi@gentoo.org>2010-06-01 16:17:05 +0000
commitee999173a6e46dfb35758d9b00e3a803ad6a2a8b (patch)
treed655ccf41d4f7642ce08a3ae431ee0f1f0e93962 /dev-lang/php/files
parentVersion bump dev-vcs/mercurial to 1.5.4. (diff)
downloadhistorical-ee999173a6e46dfb35758d9b00e3a803ad6a2a8b.tar.gz
historical-ee999173a6e46dfb35758d9b00e3a803ad6a2a8b.tar.bz2
historical-ee999173a6e46dfb35758d9b00e3a803ad6a2a8b.zip
fix use desc, add mbstring, fix file versioning
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-lang/php/files')
-rw-r--r--dev-lang/php/files/eblits/common-v2.eblit10
-rw-r--r--dev-lang/php/files/eblits/src_compile-v2.eblit87
-rw-r--r--dev-lang/php/files/eblits/src_install-v2.eblit115
-rw-r--r--dev-lang/php/files/eblits/src_prepare-v1.eblit5
4 files changed, 1 insertions, 216 deletions
diff --git a/dev-lang/php/files/eblits/common-v2.eblit b/dev-lang/php/files/eblits/common-v2.eblit
deleted file mode 100644
index 519a7c938db6..000000000000
--- a/dev-lang/php/files/eblits/common-v2.eblit
+++ /dev/null
@@ -1,10 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/common-v2.eblit,v 1.1 2010/05/27 23:05:04 mabi Exp $
-
-php_set_ini_dir() {
- PHP_INI_DIR="/etc/php/${1}-php${PHP_MV}"
- PHP_EXT_INI_DIR="${PHP_INI_DIR}/ext"
- PHP_EXT_INI_DIR_ACTIVE="${PHP_INI_DIR}/ext-active"
-}
-
diff --git a/dev-lang/php/files/eblits/src_compile-v2.eblit b/dev-lang/php/files/eblits/src_compile-v2.eblit
deleted file mode 100644
index 40423e154b8c..000000000000
--- a/dev-lang/php/files/eblits/src_compile-v2.eblit
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_compile-v2.eblit,v 1.1 2010/05/27 23:05:04 mabi Exp $
-
-eblit-php-src_compile() {
- SAPI_DIR="${WORKDIR}/sapis"
- local is_first_sapi=1
-
- for sapi in ${SAPIS} ; do
- use "${sapi}" || continue
- if [[ ${is_first_sapi} == 1 ]]; then
- is_first_sapi=0
- else
- emake clean
- fi
-
- php_sapi_build "${sapi}"
- php_sapi_copy "${sapi}"
- done
-}
-
-php_sapi_build() {
- local sapi="$1"
- php_set_ini_dir "${sapi}"
-
- mkdir -p "${SAPI_DIR}/${sapi}"
-
- sapi_conf="${my_conf} --with-config-file-path=${PHP_INI_DIR}
- --with-config-file-scan-dir=${PHP_EXT_INI_DIR_ACTIVE}"
-
- for one_sapi in $SAPIS ; do
- case "$one_sapi" in
- cli|cgi|embed)
- if [[ "${one_sapi}" == "${sapi}" ]] ; then
- sapi_conf="${sapi_conf} --enable-${available_sapi}"
- else
- sapi_conf="${sapi_conf} --disable-${available_sapi}"
- fi
- ;;
-
- apache2)
- if [[ "${one_sapi}" == "${sapi}" ]] ; then
- sapi_conf="${sapi_conf} --with-apxs2=/usr/sbin/apxs"
- else
- sapi_conf="${sapi_conf} --without-apxs2"
- fi
- ;;
-
- esac
- done
-
- econf ${sapi_conf}
- emake || die "emake failed"
-}
-
-php_sapi_copy() {
- local sapi="$1"
- local source=""
-
- case "$sapi" in
- cli)
- source="sapi/cli/php"
- ;;
- cgi)
- source="sapi/cgi/php-cgi"
- ;;
- embed)
- source="libs/libphp${PHP_MV}.so"
- ;;
-
- apache2)
- # apache2 is a special case; the necessary files
- # (yes, multiple) are copied by make install, not
- # by the ebuild; that's the reason, why apache2 has
- # to be the last sapi
- emake INSTALL_ROOT="${SAPI_DIR}/${sapi}/" install-sapi
- ;;
-
- *)
- die "unhandled sapi in php_sapi_copy"
- ;;
- esac
-
- if [[ "${source}" ]] ; then
- cp "$source" "${SAPI_DIR}/$sapi" || die "Unable to copy ${sapi} SAPI"
- fi
-}
diff --git a/dev-lang/php/files/eblits/src_install-v2.eblit b/dev-lang/php/files/eblits/src_install-v2.eblit
deleted file mode 100644
index e592109227ae..000000000000
--- a/dev-lang/php/files/eblits/src_install-v2.eblit
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_install-v2.eblit,v 1.1 2010/05/27 23:05:04 mabi Exp $
-
-eblit-php-src_install() {
- # Makefile forgets to create this before trying to write to it...
- dodir "${PHP_DESTDIR}/bin"
-
- # Install php environment (without any sapis)
- emake INSTALL_ROOT="${D}" \
- install-build install-headers install-programs \
- || die "emake install failed"
-
- local extension_dir="$("${D}/${PHP_DESTDIR}/bin/php-config" --extension-dir)"
-
- # And install the modules to it
- if use sharedext ; then
- insinto "${extension_dir}"
- doins "${S}/modules/"*.so
- fi
-
- # Generate the USE file for PHP
- phpconfutils_generate_usefile
-
- # Create the directory where we'll put version-specific php scripts
- keepdir /usr/share/php${PHP_MV}
-
- local sapi="", file=""
-
- for sapi in ${SAPIS}; do
- if use "${sapi}" ; then
- einfo "Installing SAPI: ${sapi}"
- # needed each time, php_install_ini would reset it
- into "${PHP_DESTDIR}"
- file=$(find "${SAPI_DIR}/${sapi}/" -type f | head -n 1)
-
- if [[ "${file: -3}" == ".so" ]]; then
- if [[ "${sapi}" == "apache2" ]]; then
- insinto "${PHP_DESTDIR}/../apache2/modules/"
- newins "${file}" "${file/*\/}"
- else
- dolib.so "${file}" || die "Unable to install ${sapi} sapi"
- fi
- else
- dobin "${file}" || die "Unable to install ${sapi} sapi"
- fi
-
- php_install_ini "${sapi}"
- fi
- done
-
- # Install env.d files
- newenvd "${FILESDIR}/20php${PHP_MV}-envd" \
- "20php${PHP_MV}"
- sed -e "s|/lib/|/$(get_libdir)/|g" -i \
- "${D}/etc/env.d/20php${PHP_MV}"
-}
-
-php_install_ini() {
- local phpsapi="${1}"
-
- # work out where we are installing the ini file
- php_set_ini_dir "${phpsapi}"
-
- local phpinisrc="${PHP_INI_UPSTREAM}-${phpsapi}"
- cp "${PHP_INI_UPSTREAM}" "${phpinisrc}"
-
- # default to expose_php=Off, bug 300695
- sed -e 's|^expose_php .*|expose_php = Off|g' -i "${phpinisrc}"
-
- # Set the extension dir
- sed -e "s|^extension_dir .*$|extension_dir = ${extension_dir}|g" -i "${phpinisrc}"
-
- # Set the include path to point to where we want to find PEAR packages
- sed -e 's|^;include_path = ".:/php/includes".*|include_path = ".:/usr/share/php'${PHP_MV}':/usr/share/php"|' -i "${phpinisrc}"
-
- dodir "${PHP_INI_DIR}"
- insinto "${PHP_INI_DIR}"
- newins "${phpinisrc}" "${PHP_INI_FILE}"
-
- dodir "${PHP_EXT_INI_DIR}"
- dodir "${PHP_EXT_INI_DIR_ACTIVE}"
-
- # Install any extensions built as shared objects
- if use sharedext ; then
- insinto "${PHP_EXT_INI_DIR}"
- for extension in "${D}/${extension_dir}/"*.so ; do
- extension="${extension##*/}"
- inifilename="${extension/.so/.ini}"
- echo "extension=${extension}" > "${S}/modules/$inifilename"
- doins "${S}/modules/$inifilename"
- dosym "${PHP_EXT_INI_DIR}/${inifilename}" "${PHP_EXT_INI_DIR_ACTIVE}/${inifilename}"
- done
- fi
-
- # SAPI-specific handling
- if [[ "${sapi}" == "apache2" ]] ; then
- if use concurrentmodphp ; then
- einfo "Installing Apache2 config file 70_mod_php${PHP_MV}_concurr.conf"
- insinto "${APACHE_MODULES_CONFDIR}"
- newins "${FILESDIR}/70_mod_php${PHP_MV}_concurr.conf-apache2" \
- "70_mod_php${PHP_MV}_concurr.conf"
-
- # Put the ld version script in the right place so
- # it's always accessible
- insinto "/var/lib/php-pkg/${CATEGORY}/${PN}-${PVR}/"
- doins "${FILESDIR}/php${PHP_MV}-ldvs"
- else
- einfo "Installing Apache2 config 70_mod_php${PHP_MV}.conf)"
- insinto ${APACHE_MODULES_CONFDIR}
- newins "${FILESDIR}/70_mod_php${PHP_MV}.conf-apache2" \
- "70_mod_php${PHP_MV}.conf"
- fi
- fi
-}
diff --git a/dev-lang/php/files/eblits/src_prepare-v1.eblit b/dev-lang/php/files/eblits/src_prepare-v1.eblit
index e8d7ae2a3290..d6856b8bf497 100644
--- a/dev-lang/php/files/eblits/src_prepare-v1.eblit
+++ b/dev-lang/php/files/eblits/src_prepare-v1.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_prepare-v1.eblit,v 1.2 2010/05/28 11:32:55 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_prepare-v1.eblit,v 1.3 2010/06/01 16:17:05 mabi Exp $
eblit-php-src_prepare() {
# USE=sharedmem (session/mod_mm to be exact) tries to mmap() this path
@@ -31,9 +31,6 @@ eblit-php-src_prepare() {
sed -e 's/PHP_UNAME=`uname -a | xargs`/PHP_UNAME=`uname -s -n -r -v | xargs`/g' \
-i configure.in || die "Failed to fix server platform name"
- # Disable interactive make test
- sed -e 's/'`echo "\!getenv('NO_INTERACTION')"`'/false/g' -i run-tests.php
-
# Prevent PHP from activating the Apache config,
# as we will do that ourselves
sed -i \